Mozilla.exe process remains running after playing Java-based game on pogo.com and exiting Mozilla

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
15 years ago
8 years ago

People

(Reporter: rick3271, Assigned: yuanyi21)

Tracking

({crash})

Trunk
x86
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040302 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:) Gecko/20040307

After playing a Java based game at http://www.pogo.com, when you exit Mozilla,
the mozilla.exe process remains running.  If you attempt to start a new Mozilla
browser session, you are presented with the Mozilla Profile Manager along with a
message that the selected profile is already in use.  Mozilla will not start
from this point unless the existing mozilla.exe process is ended.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.pogo.com
2. Choose to play one of the Java games.  "Word Whomp" and "First Class
Solitaire" produced the problem consistently for me
3. After the Java applet has loaded, exit the browser and close all Mozilla windows.
Actual Results:  
If you attempt to start Mozilla again - you will be presented with the Profile
Manager.  If you check the Process list, you will see a mozilla.exe process
still running. It is necessary to manually end the existing mozilla.exe process
in order to start the browser again.

Expected Results:  
Mozilla should have exited cleanly and its process should have terminated on its
own.

This bug was first experienced using Firefox (Mozilla/5.0 (Windows; U; Windows
NT 5.1; en-US; rv:1.7b) Gecko/20040302 Firefox/0.8.0+). Does not appear to be
theme related.  Sun Java 1.42_03 is the installed JRE.   I have reproduced this
problem on two Windows XP SP1 machines, and one Windows 2000 SP4 machine.  Does
not appear to be configuration specific.  Cannot verify if it occurs on other OS
platforms at this time.

Comment 1

15 years ago
Moving to Java:OJI
blocks bug 194663
kinda looks like bug 207191
Assignee: general → kyle.yuan
Blocks: 194663
Component: Browser-General → Java: OJI
Keywords: crash

Comment 2

15 years ago
I can confirm this bug with 2004041608 mozilla 1.7 branch build on windows XP.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

15 years ago
*** Bug 241859 has been marked as a duplicate of this bug. ***

Comment 4

15 years ago
Add myself on the list.

Comment 5

15 years ago
I don't think this is Java related bug. Basically all the Java thread is alive
when the browser has been shut down. Here is the stack trace of different Java
threads including the main browser thread (turning -verbose in Java Control Panel).

"Java Sound Event Dispatcher" daemon prio=4 tid=0x0c236780 nid=0x35c in Object.w
ait() [0x0d21f000..0x0d21fbe8]
        at java.lang.Object.wait(Native Method)
        - waiting on <0x2304a490> (a com.sun.media.sound.EventDispatcher)
        at java.lang.Object.wait(Unknown Source)
        at com.sun.media.sound.EventDispatcher.dispatchEvents(Unknown Source)
        - locked <0x2304a490> (a com.sun.media.sound.EventDispatcher)
        at com.sun.media.sound.EventDispatcher.run(Unknown Source)
        at java.lang.Thread.run(Unknown Source)

"traceMsgQueueThread" prio=5 tid=0x077e9d20 nid=0x340 in Object.wait() [0x0be8f0
00..0x0be8fc68]
        at java.lang.Object.wait(Native Method)
        - waiting on <0x22f9cff0> (a java.util.ArrayList)
        at java.lang.Object.wait(Unknown Source)
        at com.sun.deploy.util.Trace$TraceMsgQueueChecker.run(Trace.java:72)
        - locked <0x22f9cff0> (a java.util.ArrayList)
        at java.lang.Thread.run(Unknown Source)

"AWT-Windows" daemon prio=7 tid=0x050beeb8 nid=0x790 runnable [0x0bc8f000..0x0bc
8fce8]
        at sun.awt.windows.WToolkit.eventLoop(Native Method)
        at sun.awt.windows.WToolkit.run(Unknown Source)
        at java.lang.Thread.run(Unknown Source)

"Java2D Disposer" daemon prio=10 tid=0x077e4720 nid=0x3d0 in Object.wait() [0x0b
a8f000..0x0ba8f9e8]
        at java.lang.Object.wait(Native Method)
        - waiting on <0x22f72cc0> (a java.lang.ref.ReferenceQueue$Lock)
        at java.lang.ref.ReferenceQueue.remove(Unknown Source)
        - locked <0x22f72cc0> (a java.lang.ref.ReferenceQueue$Lock)
        at java.lang.ref.ReferenceQueue.remove(Unknown Source)
        at sun.java2d.Disposer.run(Unknown Source)
        at java.lang.Thread.run(Unknown Source)

"Low Memory Detector" daemon prio=5 tid=0x05069710 nid=0x51c runnable [0x0000000
0..0x00000000]

"CompilerThread0" daemon prio=10 tid=0x05068380 nid=0xf70 waiting on condition [
0x00000000..0x075bf840]

"Signal Dispatcher" daemon prio=10 tid=0x050675e8 nid=0x524 waiting on condition
 [0x00000000..0x00000000]

"Finalizer" daemon prio=9 tid=0x05064108 nid=0x538 in Object.wait() [0x073bf000.
.0x073bfc68]
        at java.lang.Object.wait(Native Method)
        - waiting on <0x22f72e68> (a java.lang.ref.ReferenceQueue$Lock)
        at java.lang.ref.ReferenceQueue.remove(Unknown Source)
        - locked <0x22f72e68> (a java.lang.ref.ReferenceQueue$Lock)
        at java.lang.ref.ReferenceQueue.remove(Unknown Source)
        at java.lang.ref.Finalizer$FinalizerThread.run(Unknown Source)

"Reference Handler" daemon prio=10 tid=0x05063440 nid=0x6c0 in Object.wait() [0x
072bf000..0x072bfce8]
        at java.lang.Object.wait(Native Method)
        - waiting on <0x22f72ee8> (a java.lang.ref.Reference$Lock)
        at java.lang.Object.wait(Unknown Source)
        at java.lang.ref.Reference$ReferenceHandler.run(Unknown Source)
        - locked <0x22f72ee8> (a java.lang.ref.Reference$Lock)

"main" prio=5 tid=0x0028de80 nid=0x69c runnable [0x00000000..0x0012e848]

"VM Thread" prio=10 tid=0x05060ba0 nid=0x6cc runnable

"VM Periodic Task Thread" prio=10 tid=0x0506aa48 nid=0x680 waiting on condition

So we should reassign this bug to other appropriate categories.

Comment 6

15 years ago
Bug 236540 related?

Comment 7

15 years ago
I have also seen this behavior.  I have seen it on multiple Windows 2000 and
Windows XP systems.  It seems exclusive to Windows.  I have not had an
opportunity to see if it affects Windows 9x systems.  It also does not seem to
be exclusive to Pogo.  This is almost certainly the same bug as #236540.  I
cannot say whether the problem is with Mozilla or with Java.  Has anyone seen
similar behavior with other plugins?  Can we narrow down what versions of
Mozilla are affected?  There are also reports of problems arrising that people
have been unable to play Pogo games with Mozilla.  The games fail to load
following the advertisement.  Is is possible that these problems are somehow
related?

Comment 8

15 years ago
Kyle,
 Would you please take a look at it?
 Thanks.

Comment 9

15 years ago
I ha same problems on Firefox 0.8 and 0.9 and mozilla 1.6 and 1.7 using Win98se

Comment 10

15 years ago
Frequently reproduced with Firefox 0.9 and Mozilla 1.7 on Windows XP.  The
failure sequence in the browser seems to be the same with both:

1. Page freezes (URLs not actionable).
2. CTRL-Q ==> The browser exits, seemingly without issues.
3. A zombie process is left running in background and a Java ICON is visible in
the system tray.

I have never been able to reproduce this error on Fedora Core 2 Linux with
Mozilla 1.7 since Mozilla 1.7.  The Windows XP environment anomaly was present
in Mozilla 1.6 too and I was not ever able to reproduce this anomaly in Redhat 9
or Fedora Core 1 with Mozilla 1.6. 

I have been using Java SDK 1.4.2_04-b05 in all environemnts since it was
available from Sun.  Previously, I was using Java SDK 1.4.1_07 for a long time
before that.
(Assignee)

Comment 11

15 years ago
taking...
Status: NEW → ASSIGNED

Comment 12

14 years ago
Probably related or a dup of bug 240105?

Comment 13

14 years ago
This wfm using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050409 Firefox/1.0+
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 14

14 years ago
*** Bug 229281 has been marked as a duplicate of this bug. ***

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.