popup message block current downloads

RESOLVED DUPLICATE of bug 74331

Status

defect
RESOLVED DUPLICATE of bug 74331
15 years ago
15 years ago

People

(Reporter: norsay, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040218
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040218

During a file download, if a popup message is open ("you've got a mail" style),
the download stops and then timeouts if the popup is not clicked

Reproducible: Always
Steps to Reproduce:
1. launch a file download
2. open a page with a message popup
3. watch your download stops and timeouts

Actual Results:  
The download is stopped

Expected Results:  
Continue the download while displaying the popup and waiting for the user click.
Indeed, the popup should even be relative only to the page that opened it, and
should not block every input for the whole browser
(Reporter)

Updated

15 years ago
Component: Download Manager → Browser-General
OS: Linux → All

Comment 1

15 years ago
Are you talking about dialog windows?
If yes, then this is a duplicate of bug 74331.
(Reporter)

Comment 2

15 years ago
I was talking about javascript alert

Comment 3

15 years ago
(In reply to comment #2)
> I was talking about javascript alert

An alert dialog is a modal dialog. I think it is a dupe of bug 74331.
(Reporter)

Comment 4

15 years ago
ok, maybe you'right. i was confused by your "modal windows", thought you spoke
specifically about browsing windows.. so, ok, duplicate :)

*** This bug has been marked as a duplicate of 74331 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.