E-mails with non-embedded file: links to text files don't work

RESOLVED DUPLICATE of bug 84128

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 84128
13 years ago
13 years ago

People

(Reporter: Serge Lalonde, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

E-mails received with file: links to local text files (and I presume any other
kind of file) on a network don't open from the mail reader. Right-clicking and
using "Copy Link Location" and then pasting it into the URL bar in a Browser
window does work. If it works in the Browser, then the link should also work in
the Mail reader.

In Mozilla 1.4 (I think), it used to sometimes work by right-clicking and
choosing "Open Link in new Tab", however this is no longer true.

I've read bug report 132257, but this is different. The e-mails are
automatically generated by our automated build system (with sendmail so it
bypasses Mozilla altogether to send the e-mail) to send the link to the build
log files which are several megabyes in size. Embedding the log file is not an
option.

Reproducible: Always
Steps to Reproduce:
1. Use the Mail Composer to insert a link to a network file. The file should be
a plain Text file and the link path should be a UNC path.
2. Use the Advanced Options to set the moz-do-not-send attribute to true (to
avoid embedding the file).
3. Assuming there is a PC on the network called BuilderPC, the HTML code for the
link would look like the following:
<a moz-do-not-send="true"
href="file://///BuilderPC/C/BuildLogs/afternoon_build2004_Mar_04_05_54_PM_EST.log">Build
Report</a><br>
In fact, you could copy and paste this using the Insert->HTML... menu item and
simply edit the file path.
4. Send the mail to yourself.
Actual Results:  
Clicking on the link to the file does nothing.
Copying the link address and pasting it into a Browser's address bar loads the
file successfully.

Expected Results:  
Should open the text file a new window (or Tab if "Open Link in new Tab") was
selected.

Comment 1

13 years ago
dupe of bug 84128?
(Reporter)

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 84128 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.