Closed Bug 236854 Opened 19 years ago Closed 19 years ago

Wingdings font cannot be specified using CSS

Categories

(SeaMonkey :: General, defect)

x86
Windows 2000
defect
Not set
major

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: venya, Assigned: dbaron)

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

This HTML code should produce equal results:
<div><font face="Wingdings">nox</font></div>
<div style="font-family:Wingdings">nox</div>
but it doesnt!
Other fonts works fine

Reproducible: Always
Steps to Reproduce:
1. create HTML
2. specify font Wingdings for some text via CSS (either style or class)
3. Open in Firefox

Actual Results:  
text appears in different font when CSS used, but Wingdings can be specified 
with <font>

Expected Results:  
<div><font face="Wingdings">nox</font></div>
<div style="font-family:Wingdings">nox</div>

Should looks exactly the same!
It's not supposed to work that way.  If you put an "a" in the document, Mozilla
is supposed to display an "a", and Wingdings doesn't have an "a".

However, see http://unicode.org/charts/ and especially
http://unicode.org/charts/PDF/U2600.pdf and
http://unicode.org/charts/PDF/U2700.pdf , which can be used via numeric
character references (NCRs) (e.g., &#x263A;) if you're using a character
encoding that doesn't allow them to be transmitted directly.
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → INVALID
Wingdings have "a"! It just looksa different.

This not working anyway:
<div><font face="Wingdings">nox&#110;&#111;</font></div>
<div style="font-family:Wingdings">nox&#110;&#111;</div>

Its not about character encoding, but font is not assigned with CSS
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Nope, the information in the font says that it's not really an "a".
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → INVALID
OK. I dont want "a", i want &#97; !

<div style="font-family:Wingdings">&#97;</div>

still don't work!
CSS property font-family should be able to assign ANY font to any text object!
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Please stop reopening the bug.

&#97; is always an "a".  You want the correct unicode codepoint.
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → INVALID
This MUST be rendered equal:
<div><font face="Wingdings">a</font></div>
<div style="font-family:Wingdings">a</div>

THIS IS WHY MOZILLA WILL ALLWAYS SUUUUUCCCCCKKKKK!!
Because of stupid or lazy testers and developers.

The problem exist. but you are an idiot!
Severity: normal → major
Status: RESOLVED → UNCONFIRMED
Component: Style System (CSS) → Browser-General
Resolution: INVALID → ---
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → INVALID
What an unpleasant and ignorant creature  I was going to disable its bugzilla
account, but it looks like someone beat me to it.

/be
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.