Blank page with <NOLAYER> tag

VERIFIED FIXED

Status

P2
major
VERIFIED FIXED
20 years ago
10 years ago

People

(Reporter: elig, Assigned: rickg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
* TITLE/SUMMARY
[PP] Banner ad in SlashDot gets dragged across page during scroll <NOLAYER tag>

* STEPS TO REPRODUCE
0) Launch Viewer
1) View www.slashdot.org
2) Scroll down the page

* RESULT
 - What happened

The banner ad doesn't scroll with the rest of the text, but remains on-screen in
the same location.

 - What was expected

Behavior equivalent to Win32 or RTM Communicator 4.5.

I've enclosed an HTML snippet that will demonstrate this behavior on Mac Viewer -
-- but the same snippet doesn't render on Communicator or Win32 viewer, so I'm
guessing I've broken it a bit. (normal slashdot.org works fine on those user
agents, however.)

(not quite sure how ilayers work; don't see 'em in HTML 4 spec. Is this CSS?)

* REGRESSION

 - Occurs On
        viewer (1.13.99 optimized build for Mac OS)

 - Doesn't Occur On
        viewer (1.12.99 optimized build for Win32 [NT 4, Service Pack 3])
        viewer (1.13.99 optimized build for Linux --- build is broken, didn't
check)


* CONFIGURATIONS TESTED

- PowerMac 8500/120 (233 Mhz 604e), 64 MB RAM, 1024x768 (16-bit video), Mac OS
8.5.1

* HTML SNIPPET

(Note that problem goes away if you remove the <NOLAYER> tags.)

<HTML>
<BODY>

<NOLAYER>

<IFRAME src="http://adfu.blockstackers.com/servfu.pl?l,slashdot" scrolling="no"
marginwidth="0" marginheight="0" framespacing="0" frameborder="0"
width="480" height="80">
</IFRAME>
</NOLAYER>

foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo
foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo
foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo
foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo
foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo
foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo
foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo
foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo
foo

</BODY>
</HTML>

Updated

20 years ago
Summary: [PP] Banner ad in SlashDot gets dragged across page while page is scrolled → [PP] IFRAMEs not scrolling with content on Mac

Comment 1

20 years ago
This is also shown on sample 9.

Updated

20 years ago
Assignee: sdagley → pierre
Severity: normal → major

Comment 2

20 years ago
Marking as severity=major as it's not a crash or development blocker.

Reassigning to pierre as it's a core issue and may need to be resolved in Gecko
land.  Kick it back if you don't agree and we can find a new owner.

Comment 3

20 years ago
I'll take it. It may be a dup of 2208 "Form controls don't work".

Updated

20 years ago
Summary: [PP] IFRAMEs not scrolling with content on Mac → [PP] (mostly fixed) IFRAMEs not scrolling with content on Mac

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 4

20 years ago
Added "(mostly fixed)" to the summary line: slashDot displays much better

Comment 5

20 years ago
"slashdot.org" has been fixed by magic but the "foo" example still doesn't
display anything unless you remove the <NOLAYER> tags.

Could you test it on Windows? (I don't have a machine)
(Reporter)

Comment 6

20 years ago
Sure; will check tonight or tomorrow.
(Reporter)

Comment 7

20 years ago
Hi, Pierre ---

This appears to be cross-platform at this point. Specifically, using the 1.21.99
Seamonkey builds:

* Slashdot views correctly on both Mac OS and Win32.
* The "foo foo foo" test case doesn't work on either Mac OS or Win32.

Updated

20 years ago
Assignee: pierre → rickg
Status: ASSIGNED → NEW
OS: Mac System 8.5 → All
Hardware: Macintosh → All
Summary: [PP] (mostly fixed) IFRAMEs not scrolling with content on Mac → Blank page with <NOLAYER> tag

Comment 8

20 years ago
Removed [PP] tag, renamed to "Blank page with <NOLAYER> tag", changed platform to
All and reassigned to rickg because it may be a problem with the parser.
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

20 years ago
The nolayer, noscript and noframes sections no longer get passed into our
content model. Please retest with next build.
(Reporter)

Updated

20 years ago
Status: RESOLVED → REOPENED
(Reporter)

Updated

20 years ago
Resolution: FIXED → ---
(Reporter)

Comment 10

20 years ago
Re-opening. Still takes place using 1.25.99 builds on Win32 (NT4), Mac OS, and
Red Hat Linux.

[put snippet at http://www.prometheus-music.com/gecko/bug2369.html for
convenience purposes.]
(Reporter)

Updated

20 years ago
QA Contact: 1698
(Reporter)

Updated

20 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 11

20 years ago
Verified fixed cross-platform on:

	2.3.99 builds: Win32 & Linux
	2.2.99 build: Mac OS

Comment 12

19 years ago
*** Bug 3573 has been marked as a duplicate of this bug. ***
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.