Status

defect
P2
major
VERIFIED FIXED
21 years ago
11 years ago

People

(Reporter: elig, Assigned: rickg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

* TITLE/SUMMARY
[PP] Banner ad in SlashDot gets dragged across page during scroll <NOLAYER tag>

* STEPS TO REPRODUCE
0) Launch Viewer
1) View www.slashdot.org
2) Scroll down the page

* RESULT
 - What happened

The banner ad doesn't scroll with the rest of the text, but remains on-screen in
the same location.

 - What was expected

Behavior equivalent to Win32 or RTM Communicator 4.5.

I've enclosed an HTML snippet that will demonstrate this behavior on Mac Viewer -
-- but the same snippet doesn't render on Communicator or Win32 viewer, so I'm
guessing I've broken it a bit. (normal slashdot.org works fine on those user
agents, however.)

(not quite sure how ilayers work; don't see 'em in HTML 4 spec. Is this CSS?)

* REGRESSION

 - Occurs On
        viewer (1.13.99 optimized build for Mac OS)

 - Doesn't Occur On
        viewer (1.12.99 optimized build for Win32 [NT 4, Service Pack 3])
        viewer (1.13.99 optimized build for Linux --- build is broken, didn't
check)


* CONFIGURATIONS TESTED

- PowerMac 8500/120 (233 Mhz 604e), 64 MB RAM, 1024x768 (16-bit video), Mac OS
8.5.1

* HTML SNIPPET

(Note that problem goes away if you remove the <NOLAYER> tags.)

<HTML>
<BODY>

<NOLAYER>

<IFRAME src="http://adfu.blockstackers.com/servfu.pl?l,slashdot" scrolling="no"
marginwidth="0" marginheight="0" framespacing="0" frameborder="0"
width="480" height="80">
</IFRAME>
</NOLAYER>

foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo
foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo
foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo
foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo
foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo
foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo
foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo
foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo foo
foo

</BODY>
</HTML>
Summary: [PP] Banner ad in SlashDot gets dragged across page while page is scrolled → [PP] IFRAMEs not scrolling with content on Mac
This is also shown on sample 9.
Assignee: sdagley → pierre
Severity: normal → major
Marking as severity=major as it's not a crash or development blocker.

Reassigning to pierre as it's a core issue and may need to be resolved in Gecko
land.  Kick it back if you don't agree and we can find a new owner.
I'll take it. It may be a dup of 2208 "Form controls don't work".
Summary: [PP] IFRAMEs not scrolling with content on Mac → [PP] (mostly fixed) IFRAMEs not scrolling with content on Mac
Status: NEW → ASSIGNED
Added "(mostly fixed)" to the summary line: slashDot displays much better
"slashdot.org" has been fixed by magic but the "foo" example still doesn't
display anything unless you remove the <NOLAYER> tags.

Could you test it on Windows? (I don't have a machine)
Sure; will check tonight or tomorrow.
Hi, Pierre ---

This appears to be cross-platform at this point. Specifically, using the 1.21.99
Seamonkey builds:

* Slashdot views correctly on both Mac OS and Win32.
* The "foo foo foo" test case doesn't work on either Mac OS or Win32.
Assignee: pierre → rickg
Status: ASSIGNED → NEW
OS: Mac System 8.5 → All
Hardware: Macintosh → All
Summary: [PP] (mostly fixed) IFRAMEs not scrolling with content on Mac → Blank page with <NOLAYER> tag
Removed [PP] tag, renamed to "Blank page with <NOLAYER> tag", changed platform to
All and reassigned to rickg because it may be a problem with the parser.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
The nolayer, noscript and noframes sections no longer get passed into our
content model. Please retest with next build.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Re-opening. Still takes place using 1.25.99 builds on Win32 (NT4), Mac OS, and
Red Hat Linux.

[put snippet at http://www.prometheus-music.com/gecko/bug2369.html for
convenience purposes.]
QA Contact: 1698
Status: RESOLVED → VERIFIED
Verified fixed cross-platform on:

	2.3.99 builds: Win32 & Linux
	2.2.99 build: Mac OS
*** Bug 3573 has been marked as a duplicate of this bug. ***
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.