Crash with long file names containing characters such as "ç"

RESOLVED DUPLICATE of bug 225125

Status

--
critical
RESOLVED DUPLICATE of bug 225125
15 years ago
14 years ago

People

(Reporter: freud, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20040130 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20040130 Firebird/0.7

When using the "save link to disk" option, or any other that pops up a file
dialog, Mozilla and Mozilla Firebird crash. After some hours of investigation, I
could finally find the cause : a long file name containing a "ç" in my home
directory. The file name is :
"Alias.2xNN.sous-titres.srt.français.saison.2.complete.zip".
If I replace the "ç" by a "c", it doesn't crash any more. If I change the
filename to "français.zip", it doesn't crash any more either.

Reproducible: Always
Steps to Reproduce:
1.Create a file in a directory named as above,
"Alias.2xNN.sous-titres.srt.français.saison.2.complete.zip".
2.Find a link (shouldn't be difficult ;)) on the web, right-click and choose
"Save link to disk".
3.Browse the file dialog popup to the directory where is the file named as
above, it will crash.

Actual Results:  
Total crash, all the windows of the navigator just get closed.

Expected Results:  
Not crashed ;) and write the file name correctly.
upgrade, this is fixed in 1.6

*** This bug has been marked as a duplicate of 225125 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.