If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Tabbing into text input field with onfocus="this.blur()" hangs Mozilla. Clicking into same field works fine.

VERIFIED DUPLICATE of bug 232368

Status

()

Core
DOM: Core & HTML
--
critical
VERIFIED DUPLICATE of bug 232368
14 years ago
14 years ago

People

(Reporter: A. Yau, Unassigned)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6) Gecko/20040113

A technique for making text fields read-only (rightly or wrongly) is with
onfocus="this.blur()". This sample page exhibits the defect:

<html>
<head></head>
<body>
<form>
src: <input type=text name=infld  value=src>
<input type=button value=Copy
onClick="document.forms[0].outfld.value=document.forms[0].infld.value;"><br>
dst: <input type=text name=outfld value=dst onfocus="this.blur()">
</form>
</body>
</html>

I may have filed this in the wrong place and I am certainly not an expert HTML
or javascript programmer.

Reproducible: Always
Steps to Reproduce:
1.click in src field of sample page
2.tab through to dst field
3.<hang>

Actual Results:  
Mozilla hangs/freezes. Windows is unaffected.

Expected Results:  
Focus should have cycled through to the address bar or back to the src field.
(Reporter)

Comment 1

14 years ago
Upon further consideration, perhaps the focus (caret?) is cycling back in the
tab order only to be reset on the blurred field, which is causing an infinite loop.

Comment 2

14 years ago
This has already been fixed.

*** This bug has been marked as a duplicate of 232368 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 3

14 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.