letters typed in search bar are intercepted by single-letter shortcuts

RESOLVED DUPLICATE of bug 199019

Status

defect
--
critical
RESOLVED DUPLICATE of bug 199019
15 years ago
15 years ago

People

(Reporter: bugzilla, Assigned: sspitzer)

Tracking

({dataloss})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7a) Gecko/20040218
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7a) Gecko/20040218

When I type a 'k' into the searchbar, the current thread is killed.

Reproducible: Always
Steps to Reproduce:
1. Klick into search bar to give it the focus
2. type a word containing 'k'
3.

Actual Results:  
The 'killed' status of the current thread is toggled.

Expected Results:  
A 'k' should appear in the search bar

This happens regardless of the position of the 'k' (in the middle of the word or
at the beginning)
(Reporter)

Updated

15 years ago
Keywords: dataloss
(Reporter)

Comment 1

15 years ago
'Reproducible: Always' seems to be wrong - I just tested again and it worked.
Can't say yet, what triggers this.
(Reporter)

Comment 2

15 years ago
This bug is not limited to Seamonkey. Can see it with TB 0.7.1 too. Should I
file another bug against TB?

Additionally, it is not limited to 'k' shortcut, but to all single-key shortcuts
in mailnews (r,c,j,...) -- changing summary.
Summary: k in searchbar is intercepted by 'kill thread' shortcut → letters typed in search bar are intercepted by single-letter shortcuts

Comment 3

15 years ago
btw: Losing typed keystrokes in the QS filter does not really qualify as 
"dataloss."

*** This bug has been marked as a duplicate of 199019 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

15 years ago
Ehm. It's not the losing letters but the killed threads, messages marked as read
etc. what I considered dataloss.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.