pop before smtp (anti spam) auth not available (as well as imap before smtp)

RESOLVED DUPLICATE of bug 81387

Status

MailNews Core
Networking: SMTP
--
enhancement
RESOLVED DUPLICATE of bug 81387
14 years ago
10 years ago

People

(Reporter: jhacker, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040122 Debian/1.6-1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040122 Debian/1.6-1

POP-before-SMTP (and IMAP-before-SMTP as well) is a widely used
authentication method used by providers to prevent spamming.
It has nothing to do with regular SMTP-Authentication.
Various other Mail readers have an option which automates the task
Mozilla users have to do by hand: Checking mail before being
able to send some.

Reproducible: Always
Steps to Reproduce:
0. Keep unconnected to the net (Affects mostly dial-up-users).
1. Open Mailnews. (e.g. by using mozilla -mail -compose)
2. Connect to your provider that uses DRAC/popbsmtp
3. Try to send a mail


Actual Results:  
Your SMTP server responds that you have to check mail before being able to send.
You have switch to inbox and click on "get messages" manually.
Retrying to send will work now.

Expected Results:  
If sending fails, mozilla should try to fetch mail automatically in the
background. If sending then works, we know that pop/imap-before-smtp
is used by that smtp-server. Set a corresponding userpref that will
do the MailCheck automatically in the future, whenever a mail is
to be sent via that smtp server.

SHAME ON ME. This is a dup of Bug #81387 (Filed Mid-2001, unresolved).
Sorry for conciously filing an existing bug, but I only need a little
hint if my approach/fix is correct by anyone actively maintaining
the source. 
Read comment #20 of that bug, give me a hint, and hate me for filing a dup...
Just did it to get an active maintainer involved here, providing hints.
Seems nobody from the #81387-CC-list is still active on that quite
important bug (or better "year-old-easily-to-solve-RFE").

Many urls provided on that topic in dup Bug #81387, Comment #20.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 81387 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.