Mozilla adds wrong file-extension when downloading files (save as)

NEW
Unassigned

Status

()

--
enhancement
15 years ago
2 years ago

People

(Reporter: Alexander_Pircher, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.5) Gecko/20031007

If downloading file.tgz with right click and "Save as" Mozilla wants to
save it as "file.tgz.GZ", if downloading with left click and then "Save to
Disk" Mozilla wants to save it as "file.tgz.TAR".

This bug may touch Bug 229787 "Downloading PDF file defaults to HTML extension
and resulting file won't open in acrobat" and Bug 181029 "chimera adds .txt to
a file without being asked".


Reproducible: Always
Steps to Reproduce:
1. Go to http://prdownloads.sourceforge.net/jboss/jboss-3.2.3.tgz?use_mirror=heanet
2. Right or left click on link and see wrong file-extension

Actual Results:  
Wrong File-Extension is added

Expected Results:  
Do not add any additional file-extension
1.5?  Please test something like a recent build... I believe Christian fixed
this since 1.5.
yes, I believe this is fixed. please test with 1.7a or something

Comment 3

15 years ago
no respone from reporter for 3 months. Resolving as WFM.
Reporter, please reopen if you still see this with a recent Moz build.
(Reporter)

Comment 4

15 years ago
I didn't had a Mozilla version greater 1.5 installed before, therefore no
response from me. I've now tested it with Mozilla 1.6:

Downloading with left click and then "Save to Disk" still doesn't work properly.
Mozilla adds now .GZ as extension -> file.tgz.GZ

Can anyone test this with 1.7 RC3?

Comment 5

15 years ago
works for me...
What do you have for application handlers, specifically x/tar? Can you try with
a blank test profile?
(Reporter)

Comment 6

15 years ago
I changed to another Un-/Compression-Tool therefore the left click
and "Save to Disk" worked now properly.

After unregistering .TAR, .GZ, .TGZ Mozilla saves the File correctly
as .TGZ. So the question is why does Mozilla 1.6. something with the
Application Handler even if you only want to save the file and not
open it with the linked application.

Comment 7

15 years ago
Officially i should dupe this, but i don't have the original one handy, so i'm
marking it wfm, per your comment 5.

As to your Q: My guess is that the application handler got horked due to a
temporary bug and then remained horked. This was then fixed as remarked by
comment 1 and not a problem anymore for newer builds/unhorked installations.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

15 years ago
Checked with Mozilla 1.7 Final, same behaviour. Mozilla adds
an additional extension.

I consider this as a Security-Bug, as someone may be able to
abuse this to force arbitrary file-extensions (like exe) and
therefore vote to change Severity to critical.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 9

15 years ago
(In reply to comment #8)
> I consider this as a Security-Bug, as someone may be able to
> abuse this to force arbitrary file-extensions (like exe) and
> therefore vote to change Severity to critical.

Can you try to install 1.7 final in a completely empty folder?
Then start Mozilla the mozilla profile manager and create a blank test profile.
Can you then try to reproduce this with the new test profile and the vanilla
mozilla?

 

(Reporter)

Comment 10

15 years ago
Same problem with a vanilla Mozilla 1.7 Installation.

BTW, Step 0 for Reproducibility would be to have a
(Un)-Compression Programm installed. See Comment #6.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Mozilla adds wrong additional file-extension when downloading files → Mozilla adds wrong file-extension when downloading files (save as)

Comment 11

14 years ago
I guess your "gulity" (un)compress utility uses the same Content-type for tgz/gz
or so (see Bug 147679).

Reporter, what are your registry entries (run regedit from Start -> Run) for ...

value of "Content Type" entry:
HKCR\.tar
HKCR\.tgz
HKCR\.gz
value of "Extension" entry for the 1-3 above located content types:
HKCR\MIME\Database\Content Type\[your_content_type_for_ext]

HKCR = HKEY_CLASSES_ROOT
(Reporter)

Comment 12

14 years ago
Sorry for the delay, I've got no E-Mail from Bugzilla about the new commenct.

There are no Content-Type entries in HKCR\.tar, HKCR\.tgz, HKCR\.gz.
All have the value "IZArc" (that's the name of the un/compress-programm)
And HKCR\MIME\Database\Content Type\IZArc does therefore not exist.

However, I'll get an eye on Bug 147679
how about HKCR\MIME\Database\Content Type\application/x-tar ? what's its value?
(Reporter)

Comment 14

14 years ago
[HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/x-tar]
"Extension"=".tar"
Product: Browser → Seamonkey

Comment 15

10 years ago
Is the same as Bug 90490?

Updated

9 years ago
Assignee: download → nobody
Component: Download & File Handling → File Handling
Product: SeaMonkey → Core
QA Contact: file-handling

Updated

2 years ago
Component: File Handling → File Handling
Product: Core → Firefox
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.