Mozilla saves two keywords with the same name for different URL's.

RESOLVED WONTFIX

Status

()

defect
RESOLVED WONTFIX
15 years ago
10 years ago

People

(Reporter: ajauhari, Assigned: p_ch)

Tracking

unspecified
Future
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.0.3705; .NET CLR 1.1.4322)
Build Identifier: 

The keyword feature in mozilla gives us the functionality off just typing the 
keyword in mozillas addressbar rather than the whole address. On taking two 
different URL's in the manage bookmarks section, we can save them with the 
same keyword. Therefore when we go enter the keyword in the address bar it 
opens the URL we saved the keyword first in and completely ignores the second 
URL. 


Reproducible: Always
Steps to Reproduce:
1. Go to Bookmarks in the menu bar of Mozilla.
2. Click on Manage Bookmarks.
3. Go to a URL listed as a bookmark and right click on it.
4. On right clicking the info tab window open up with a keyword field. Enter a 
keyword.
5. Click on ok.
6. Go to another URL and do steps 3,4,5 again and enter the same keyword as 
entered before.



Actual Results:  
We see that Bookmarks manager does not check for similar keywords and stores 
the same keyword for two different URL's. On entering the keyword in the 
address bar it opens the URL in which we saved this keyword first. On typing 
it again it still opens the previous URL and not the other URL, completely 
ignoring it

Expected Results:  
A warning should have popped up stating that the keyword has already been 
entered for a previous URL and to enter a new keyword for another URL. This 
would have told us that mozilla does check for similar keywords used in 
different URL's.

Comment 1

15 years ago
This is a duplicate of 232916.
no, it isn't

one is about allowing two bookmarks with the same name, one is about allowing
duplicate _keywords_ (not specifically the same name) and this results in
completely different issues.

Comment 3

15 years ago
yes, we should check and prevent users from creating another keyword of the same
string.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → After Firefox 1.0

Comment 4

15 years ago
Changing from enhancement to normal. This is a bug we should fix in bookmark
keywords, which has fairly prominent UI in bookmarks properties, or we should
lower the visibility or remove this feature..
Severity: enhancement → normal
*** Bug 301924 has been marked as a duplicate of this bug. ***
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
Duplicate of this bug: 381629

Comment 8

12 years ago
Instead stopping the use of a keyword multiple times, how about open every matching bookmark in it's own tab.

Comment 9

11 years ago
I second Seairth's suggestion: opening all bookmarks for a given keyword in tabs would seem to be the natural behavior.  For example, if I have a set of webpages that give me statistics on my website visitors, I might want to give them all the keyword 'stats' so that I can open them simultaneously.

Comment 10

11 years ago
I would like to see an option: either report duplicates, or open each in a tab.

Comment 11

11 years ago
This would be a great addition to firefox; a setting to either allow reporting of duplicates, or opening all bookmarks with that particular keyword.  Or for roughly the same result; having a folder maintain a keyword and opening all contained bookmarks when the folder keyword is triggered.
The awesomebar will now show you both keywords with their resulting address, so you can choose between them, and this is no more an issue.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20090207 Shiretoko/3.1b3pre
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.