If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

compiled firefox does not install Adblock extension unless offical build's chrome directory is copied into compiled version's directory

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Dave Chand, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040312 Firefox/0.8
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040312 Firefox/0.8

I have compiled firefox several times from cvs, 0.8 source, and have always had
problems getting certain extension, namely adblock, to work properly on my
compiled version of firefox. The extensions ususally work correctly after
copying the chrome directory files from the officially firefox build into my
compiled version of firefox's chrome directory. This problem occurs with and
without CFLAGS.

Reproducible: Always
Steps to Reproduce:
1. Compile Firefox 0.8 source on a Mac OSX Panther 10.3.2
2. Try to install adblock extension
http://downloads.mozdev.org/adblock/adblock-0.5-dev.xpi
3. Try to access the preferences from the Tools in the menu bar. Adblock will
not be in the menu bar, and neither will DOM inspector.
4. download the official build of firefox 0.8 for mac and mount image etc.
5. copy the chrome directory files from the official build into the chrome
directory of the your compiled build.
6. go to Tools in the menu bar, adblock and DOM Inspectory now show up in the
tools menu.
Actual Results:  
See Steps to reproduce.

Expected Results:  
Adblock preferences should be in the Tools menu, along with DOM Inspector.

This had nothing to do with CFLAGS, because I used extensive CFLAGS when I
compiled firefox, however I also compiled firefox with any CFLAGS to be certain,
and the same problem occured without the CFLAGS.
(Reporter)

Comment 1

14 years ago
*** Bug 237486 has been marked as a duplicate of this bug. ***
Dave, can you post your current .mozconfig here?
QA Contact: mconnor
resolving worksforme, most likely build-config related
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.