Junk Mail Can't Be delete Unless Junk Folder is Selected

RESOLVED DUPLICATE of bug 189911

Status

--
enhancement
RESOLVED DUPLICATE of bug 189911
15 years ago
14 years ago

People

(Reporter: pbbruce, Assigned: sspitzer)

Tracking

Trunk
x86
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.5) Gecko/20031020
Build Identifier: Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.5) Gecko/20031020

If I'm looking at my Inbox or any other folder and decide that I need to clean
up my Junk folder, I just can't goto Tools->Delete Mail Marked as Junk. I have
to click on that folder then use that click on Tools ->Delete Mail Marked as
Junk. Then it works. I think it shouldn't matter which folder your looking at
that you should be able to Delete the Junk mail as you wish.

Also this should be feature not a bug: How setup the profile so user has the
option to acutally delete that junk mail instead of having to duplicate the
effort of deleteing that junk from the trash folder also.


Reproducible: Always
Steps to Reproduce:
1. Review Junk Mail Folder
2. Select Inbox Folder
3. Select Tools-> Delete Mail Marked as Junk
Then Junk Mail doesn't get removed

4. Select Junk Folder
5. Then click Tools->Delete Mail Marked as Junk
6. Junk Mail moves to Trash Folder
7. Then right mouse click on trash Folder
8. Then select empty trash
Junk Mail is then completely removed.


Actual Results:  
In Step 1-3 the Junk Mail doesn't get removed in Steps 4-8 the Junk Mail gets
removed.

Expected Results:  
It shouldn't matter which folder is selected. The software should allow the user
to delete the junk mail no matter which folder they are in. Also I think there
should be an option to clean up the junk mail when Mail software has exited.
That also never occurs either.

Updated

15 years ago
OS: SunOS → Solaris

Comment 1

15 years ago
There is no "Delete Mail Marked as Junk" option.
It's "Delete Mail Marked as Junk in Folder". So this is not a bug: 
Changing severity.
Severity: normal → enhancement

Comment 2

15 years ago
Bug 189911 requests an 'Empty Junk' item in the Junk folder's context menu.

Comment 3

14 years ago
No response from reporter, duping.

*** This bug has been marked as a duplicate of 189911 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.