If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Maximizing doesnt fill widescreen display on Mac

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: Mark Brocato, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040312 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040312 Firefox/0.8.0+

Clicking the maximize button on the title bar does not fully maximize the window
on a widescreen display (I'm running a powerbook G4 15 inch).  It looks like
it's maximizing to the normal aspect ratio instead. 

Reproducible: Always
Steps to Reproduce:
1.Click the maximize button in the title bar (the green one with the plus)
2.
3.

Actual Results:  
Firefox expanded to 100% of the vertical area, but only about 80-90% of the
horizontal area

Expected Results:  
expand to 100% of the vertical and horizonatl area

Using View->full screen from the application menu does, however, make firefox
take up the full screen.

Comment 1

14 years ago
Zoom button (green button) on Mac is not always maximizing the window
like as on Windows.
Try Safari and Mac IE.
Camino do that behavior, but Bug 155956 is filed against it.
# Bug 232919 for SeaMonkey

Mac IE and NN 4 have a feature by option-clicking the zoom button.

This is invalid or dup of Bug 42578.

Comment 2

14 years ago
Ack!  This still exists in 0.9RC.  I'm an inexperienced OSX user, but from what
I see:

-Safari follows the same behavior as Firefox currently does.  
-IE follows the same behavior *with* the ability to option-click to fill the
screen (however, it unfortunately goes under the dock).  
-Camino and Opera fills the screen (minus the dock).

Most other OSX applications seem to follow the Camino/Opera behavior, which I
prefer.  However, if you're going to keep the current Safari behavior, at least
add the ability to option-click to the fill the screen (minus the dock).

Comment 3

14 years ago
I appologize, the behaviors are actually a little different.  Firefox does *not*
follow the behavior of Safari.

-Safari zooms to a window size that is vertically and horizontally as small as
possible to fit the whole page, unless the window was previously sized larger,
or in the case of a large enough page, it will be the height and/or width of the
screen.

-Camino zooms to a window size that simply fills the entire screen.

-Firefox zooms to a window size that appears to be a fixed ratio, filling the
screen vertically, but leaving desktop space horizontally.

These three always leave space for the dock (if unhidden).  Keep in mind, this
behavior is examined on my wide-screen PowerBook.  In my opinion, Safari's
behavior is neat, but takes getting used to.  Camino's is simple and
Windows-like.  Firefox's is simply crude, and seems to be lacking consideration.
 Please change it before 0.9 goes final!

Comment 4

13 years ago
Yes, please can we have green button change the size of the window such that it
is as small as possible without causing the scroll bars to appear.

Try using it on this url, as an example :

http://www.bbc.co.uk/radio/aod/index.shtml?button

(Safari doesn't do very well on this either, actually)

Comment 5

13 years ago
As an experienced user, I find Firefox's maximize behavior surprising.  Simply
making the window as tall as the current screen seems to me to be not even in
the top three expected behaviors.

As far as the whole "option click" of the maximize button goes, I really don't
care, so long as both behaviors are not surprising and are useful.

Adding myself as a CC to track this issue.

Comment 6

13 years ago
This bug should be marked invalid.
It's not supposed to maximize over the whole screen unless you're using full
screen view, and I believe the way it maximizes right now is better than Safari.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.3) Gecko/20041002
Firefox/0.10
Either the "green" button or the "Zoom" menu command are not intended to
maximize any window on OS X.

But:
1) We may implement option+click-on-green-button to (Bug 42578).
2) The current behavior isn't perfect (Bug 232919).

Please don't file separate bug fo ff/tb, these are "core" bugs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
QA Contact: bugs.mano
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.