firefox hangs with website that use RealPlay and Flash

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: j.aubert, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.1; Linux)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8

When I launch the windows who permit to listen radio on the specified site 
above, there is no sound and firefox hangs. Only a kill -9 command can close 
it. 

Reproducible: Always
Steps to Reproduce:
1.Use FireFox 0. with this plugins : realplayer8.0 (install with 
rp8.linux20.libc6.i386.cs2.rpm) and FlashPLayer (install with 
install_flash_player_6_linux.tar.gz). 
2.Enable cookies in firefox 
3.Go to the website : http://www.novaplanet.com 
4.Click on the area "ENTREE", there is a new window with a dynamic menu. 
5. On the right side of the dynamic menu, there is an area called "Radio Nova 
Live", click on it. 
6. A window pop-up appears and there is a plugins search. 
7. An alert dialog box inform you that you haven't a Windows Media Player 
plugins and you can donwload if you click on the OK button. 
8. Click cancel button. 
9. In the window pop-up, click on the realplayer's icon to select this 
stream's format. 
10. In this window pop-up, a line appears with the words "connecting ..." 
Actual Results:  
Nothing. So try to close the windows. First close the popup windows, then the 
second window, OK. But the first window don' close. Inside there is no content 
and only a kill -9 command can stop firefox. 

Expected Results:  
Play music and if not, we could stop firefox. 

I use Mandrake 9.2 with this kernel 2.4.22-10mdk 
gcc 3.3.1 
 
I tried to test with three profiles whose one is under root'a account. 
 
I tried with mozilla 1.6 
 
I tried with Flashfix. 
 
My plugins are recognised, i see them with mozilla "about plugins window". 
 
Nothing seems to resolve the problem.

Comment 1

15 years ago
WFM

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040321
Firefox/0.8.0+

Once I had started "Radio Nova" it took a long time to stop it or do anything
with Firefox.

I got thtese messages:

For application/x-shockwave-flash found plugin Shockwave Flash NP-PPC
For application/x-shockwave-flash found plugin Shockwave Flash NP-PPC
CSS Error (http://www.novaplanet.com/music/radionova/html/invit.asp?date=040321
:18.2): Selector expected.  Ruleset ignored due to bad selector.
CSS Error (http://www.novaplanet.com/music/radionova/html/invit.asp?date=040321
:19.0): Unexpected end of file while searching for closing } of invalid rule set.
For application/x-shockwave-flash found plugin Shockwave Flash NP-PPC
For application/x-shockwave-flash found plugin Shockwave Flash NP-PPC
For application/x-shockwave-flash found plugin Shockwave Flash NP-PPC
WARNING: trying to find screen for sizeless window, using primary monitor, file
../../../../src/gfx/src/mac/nsScreenManagerMac.cpp, line 120
For image/x-quicktime found plugin QuickTime Plugin.plugin
/Volumes/Ben/mozilla-realclean/phoenix/dist/Firefox.app/Contents/MacOS/firefox-bin:
can't map file: /Library/Internet Plug-Ins/QuickTime Plugin.plugin ((os/kern)
invalid argument)
[loaded plugin /Library/Internet Plug-Ins/QuickTime Plugin.plugin]
For application/x-shockwave-flash found plugin Shockwave Flash NP-PPC
For application/x-shockwave-flash found plugin Shockwave Flash NP-PPC
Mar 21 14:37:55 iMac024 WindowServer[416]: CGXDisableUpdate: Updates disabled by
connection 0x4b0b for over 1.000000 seconds

WARNING: Not implemented, file ../../../../src/widget/src/mac/nsMenuX.cpp, line 417
--WEBSHELL == 91
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(EnsureScriptEnvironment())) failed, file
../../../src/docshell/base/nsWebShell.cpp, line 290
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(EnsureScriptEnvironment())) failed, file
../../../src/docshell/base/nsWebShell.cpp, line 290
WARNING: Not implemented, file ../../../../src/widget/src/mac/nsMenuX.cpp, line 417

Comment 2

15 years ago
Bugday 25-05-2004.

WFM.

Today's firefox aviary based - Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040525 Firefox/0.8.0+ (MozJF)

Comment 3

14 years ago
didn't work for me using nightlies, (I submitted lots of crash reports)

I finally just disabled the plugin because it was making me loose work!

(0.9.1+)
That was when firefox was based on 1.8a2... I think nightlies are now based on
1.8a3.. but 1.0 will go off of 1.7? so nobody really cares!

Linux, Gcc 3.4 system, NPTL, Gentoo, Xorg-x11, KDE 3.2.3 and kde 3.3beta1

Comment 4

14 years ago
I can confirm this crashing with Flash, on Linux, with all nightlies.. for 
about a month.  I haven't tried realplay though. 
 
and... that on my system is has to do with sound! 
 
if I don't let it (flash) have sound... it works! 
if i give it sound with artsdsp, or even artsdsp -m, it will die a horrible 
death, taking out all of my firefoxes...  
 
If I give it direct access to the sound card (a lot of work, and my alarms 
won't go off) .. it works.  Kernel 2.6.7-gentoo-r11  alsa nforce1 motherboard 
(intel8x0 driver) 
 
 
 
brohahahah.. My system's firefox works (9.1) with systrace... 
 
my nightlies do NOT work... at all...  
and... the 9.1 on my system doesn't work with artsdsp... 
the 9.1 on my system DOES ... make that DOES NOT work with artsdsp -m 
it gets a bit farther (actually starting to render the page before it locks up 
and I'm forced to kill it) 
*********** 
(here is what the command line has to say for these) 
bash-2.05b$ artsdsp firefox 
No running windows found 
/usr/bin/firefox: line 388: 29675 Killed                  $mozbin "$@" 
bash-2.05b$ artsdsp -m firefox 
No running windows found 
/usr/bin/firefox: line 388: 29749 Killed                  $mozbin "$@" 
***************** 
(-m makes artsdsp memorymap, I can play quake3 with artsd) 
(artsd is what allowes me to have multilpe applications sharing my soundcard) 
 
 
************* 
here is a systrace... ha! it stoped long before atomfilms.com loaded, 
(systrace below) 
 
here is what showed up on that status bar...  and it worked! (but completely 
without sound :(  ) 
(at it worked again without systrace, elimiating systrace magic) 
 
resolving atom films.com 
downloading data from... 
resolving images.shockwave.com... 
more stuff 
Resolving host a.as-us.falkag.net 
Transfering data from 
Resolving host red01.as-us.falkag.net... 
 
(all this time the firefox home page is showing, with no updates) 
and... lo and behold... there is a flash picture!!!  (but no sound, because I 
didn't start firefox with artsdsp like I normally do) 
at bottom... it stopped scrolling by when the application window appeared.. I 
guess mozilla doesn't do many system calls!? 
 
*********** 
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0 
rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0 
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0 
rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0 
rt_sigaction(SIGINT, {0x807bc80, [], 0}, {SIG_DFL}, 8) = 0 
waitpid(-1, *** loading the extensions datasource 
*** ExtensionManager:checkForMismatches: no access privileges to application 
directory! 
*** loading the extensions datasource 
 
 

Comment 5

14 years ago
http://www.olympiagoldteam.com is another example of Flash that results
in browser hanging.

Comment 6

13 years ago
Bug outdated! Please use recent builds!

Comment 7

13 years ago
WFM. (Win XP Prof sp2, Firefox 1.5.0.1 ID:2006011112)

Since there has been no reply to comment #6 ==> WORKSFORME. 

The problem you are reporting may well have been fixed already. 

Could you please download a recent version or nightly build from <http://www.mozilla.org/releases/nightly.html>, and then let us know if you still see this problem? If so feel free to report back and ask for the bug to be reopened.

Many thanks, Cigno
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.