Mozilla will only display a blank page for many pages at yahoo

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
major
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: alan refalo, Unassigned)

Tracking

Bug Flags:
blocking1.7 -
blocking1.8a1 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040218
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040218

Almost all links for stories and sports from my.yahoo.com display only blank pages.

Reproducible: Always
Steps to Reproduce:
1. go to http://sports.yahoo.com
2. The page will be blank
3.

Actual Results:  
The page is blank.

Expected Results:  
Displayed the correct web page content.

Comment 1

14 years ago
Same problem with Mozilla 1.6 on XP:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

It started a couple weeks ago using a 6 month old version of Firebird. All yahoo
pages started coming up blank, with the "done" message on the status bar. I
upgraded to Moz 1.6 but still no fix. Seems as though something's changed at
yahoo. I can't find where at yahoo to complain.

Comment 2

14 years ago
I saw this for the last couple weeks with nightly builds of Firefox at
https://my.secure.yahoo.com/ but it doesn't seem to happen anymore.
(Reporter)

Updated

14 years ago
Flags: blocking1.8a+
Flags: blocking1.7+

Comment 3

14 years ago
Created attachment 144518 [details]
Error log : blank page

I was facing the same problem as mentioned in this bug:
sites:
http://yahoo.com
http://mail.yahoo.com

Using Mozilla 1.6 
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113
Tried upgrading to 1.7, but still the problem persists

From somewhere in net found that you can enable debug info on mozilla. Attached
is the log when the blank page comes.

Updated

14 years ago
Attachment #144518 - Attachment description: Error log when accessing blank page → Error log : blank page

Updated

14 years ago
Flags: blocking1.8a?
Flags: blocking1.8a+
Flags: blocking1.7?
Flags: blocking1.7+

Comment 4

14 years ago
I can't reproduce this with a recent trunk build of Mozilla 1.7 on WinXP or
Firefox 0.8 on WinXP or SuSe. Alan, can you reproduce this with a recent build?
If so, can you reproduce it with a new profile? Is there anything special about
your configuration?
(Reporter)

Comment 5

14 years ago
I pulled down the lastest nightly builds for linux and winXP.  I tried both and
they both still fail.  I also tried the linux version with a new profile and the
same for winXP to rule out any personal settings.  So I still don't know what's
going on.  The only thing I can think of is it might be the corporate firewall?
 Any ideas?

Alan

Comment 6

14 years ago
unable to reproduce on red hat enterprise linux v. 3 and fedora core 2 test 2
with Mozilla 1.7 beta and a current nightly build. I visited all of the yahoo
products without problems. 

also tested windows XP with 1.7 beta and a current Firefox nightly build. No
problems there either.

Comment 7

14 years ago
I've now checked around on a handful of other machines including Red Hat Severn
beta, Fedora Core 1 and FC2.  I tested on a second winXP system and a win2K
system and wasn't able to reproduce the problem.  

If you're seeing this problem and upgrading to a newer build doesn't solve the
problem, can you try accessing yahoo sites with a new profile? You can create
and switch to a new profile in Mozilla from the Tools -> Switch Profile... menu
item or in Firefox by running firefox.exe -ProfileManager. 

If this problem is solved by a new profile, the next step would be to determine
which file in the profile was causing the problem. The first step might be to
check clearing the cache. After that it might be worth checking some of the
networking preferences to see if those who can reproduce all have something in
common there (Edit -> Preferences -> Advanced -> HTTP Networking or about:config
filtered to "network") 

Right now, without being able to reproduce this, I don't see how we're going to
make any progress fixing it. More information from anyone experiencing it would
be really helpful. 

Comment 8

14 years ago
Now it working fine....

I am using 7.b load, last week the same load was showing the problem... but i
don't know why/how, this week it started working. I didn't changed any
pref/setting on my mozilla, but somehow the pages are loading fine.

Thanks for your efforts.
This happens constantly in IE at my library.  I don't think it's Mozilla.

(WFM, but my build is ancient - 1.6)

Comment 10

14 years ago
I am getting this problem with Mozilla 1.7b on Yahoo pages. If I go to the
following URL: http://finance.yahoo.com/q?d=t&s=HPQ then only the header of the
page will display. I can go to any stock symbol the same fashion and get the
same results. i.e. http://finance.yahoo.com/q?d=t&s=IBM or
http://finance.yahoo.com/q?d=t&s=F all result in the same behavior.

I saw this with the default version of mozilla that came with my RH 9 install. I
have since removed that version of mozilla (1.2.1) and installed 1.7b, only to
get the same results.

I have cleared both my memory and disk caches, reinstalled 1.7b, etc... but
still can not see this page. 

Comment 11

14 years ago
Related to bug 222069?

Comment 12

14 years ago
I don't see how we can block on this if we can't get reliable steps to reproduce
it. Also, if people are seeing this on Mozilla 1.2.1 (comment 10) then it's not
a recent regression and if it was a widespread problem, we'd have heard a lot
about it in 1.2 and 1.4-based releases (like Netscape 7). 
Flags: blocking1.7? → blocking1.7-
Perhaps of note, since about a week ago, Yahoo! has worked at my library.  Maybe
it was a temporary issue with Yahoo!?

Comment 14

14 years ago
This just started for me. http://my.yahoo.com/ comes up with an (Untitled) title
bar and a blank page. This started this afternoon, with a previous 1.8a. I'm now
using

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a) Gecko/20040511

and http://my.yahoo.com still comes up blank. Further, the processing time for
this page is minimal. Not more than a second or so.

Due to this happening with no change to the browser, I'm wondering if Yahoo!
changed something.

Also, I will experiment with deleting cookies, etc., and see if I can get
behavior changes.

Comment 15

14 years ago
1) Search Cookie Manager for all cookies containing "yahoo."

2) Remove those cookies.

3) Open http://my.yahoo.com

4) Get the generic My Yahoo! page, with the option to log in on the left side.

5) Log in with name and password.

6) Select "Remember my ID & Password"

7) Click "Sign In."

8) Get a blank page with this URL (in my case):

https://login.yahoo.com/config/verify?.done=http%3a//us.rd.yahoo.com/my/guest/loginbox/*http%3a//my.yahoo.com

+++

An attachment with the cookie information added by Yahoo through this login will
follow shortly.

Comment 16

14 years ago
Created attachment 148283 [details]
Text file of cookies Yahoo left on my log in.

Comment 17

14 years ago
I just tested with a brand new profile, for no change.

1) Get the un-personalized "http://my.yahoo.com/"

2) Log in as before.

3) Get "you are about to view an encrypted page" pop-up, immediately followed by
"you are about to leave an encrypted page" pop-up.

4) Get a blank page under this URL:

https://login.yahoo.com/config/verify?.done=http%3a//us.rd.yahoo.com/my/guest/loginbox/*http%3a//my.yahoo.com

5) Get these cookies put in cookies.txt:

.yahoo.com	TRUE	/	FALSE	1086158153	I
ir=cr&in=13de10cf&i1=AAASDhDmDoDpEIFZF5GAGBILKvMiOtP+P/QKfEgrBhABqJCqAD5v5x53CxAIFSHKL1L+MHMOMQMTCzACeze0DDABgN
.yahoo.com	TRUE	/	FALSE	1271361601	T
z=IXcoABIdxoAB8d1HQjN.mtyMjdOBjFON081NDYxNw--&a=YAE&sk=DAA1SeLgjy.JVD&d=c2wBTlRBNUFUWTVNRGd5TXpFMk1BLS0BYQFZQUUBb2sBWlcwLQF0aXABRFpYYzZDAXp6AUlYY29BQmdXQQ--
.yahoo.com	TRUE	/	FALSE	1271361601	Y
v=1&n=4hhbm5svufp44&l=305o33ssxx/o&p=m262ssje53qv0a00&jb=29|52|&r=1l&lg=us&intl=us
.yahoo.com	TRUE	/	FALSE	1271361601	F
a=lWdS2lYsvW_B795t8rjX4kjWpjS.y3Pp66xZ0C4sxaXAaMsLvIKYP0I1KV5R&b=tpZ4
.yahoo.com	TRUE	/	FALSE	1271361600	B	6ia592h0a3hdt&b=2
.my.yahoo.com	TRUE	/	FALSE	1271361600	V	G=1084343741

+++

So, this isn't a profile thing.

Comment 18

14 years ago
And today, the page comes up without a problem. Some weird programming change at
Yahoo? Some weird interaction with cookie's date code? Beats me...

Comment 19

14 years ago
FYI, using lynx from a UNIX shell (non-interactive) to illustrate yahoo's
reaction to certain user agents. Zero characters returned if useragent is
Mozilla/5. Suggests to me a problem internal to yahoo.

% lynx -dump -source -useragent 'Mozilla/5' http://www.yahoo.com/ | wc -c
Warning: User-Agent string does not contain "Lynx" or "L_y_n_x"!
       0
% lynx -dump -source -useragent 'Mozilla/4' http://www.yahoo.com/ | wc -c
Warning: User-Agent string does not contain "Lynx" or "L_y_n_x"!
   34041
% lynx -dump -source -useragent 'Mozilla/' http://www.yahoo.com/ | wc -c
Warning: User-Agent string does not contain "Lynx" or "L_y_n_x"!
   34041
% lynx -dump -source -useragent 'Mozilla' http://www.yahoo.com/ | wc -c
Warning: User-Agent string does not contain "Lynx" or "L_y_n_x"!
   30490

Updated

14 years ago
Flags: blocking1.8a? → blocking1.8a-

Comment 20

14 years ago
I had the same problem, was able to resolve by setting
general.useragent.overrride to MSIE

Comment 21

14 years ago
I'm told it's a proxy issue in some proxy server versions. Apparently yahoo only
enables gzip encoding for a known set of userAgents. Thus even if your browser
transmits accept-encoding:gzip (as some lynx versions and usages do), but with a
non-Mozilla/5 userAgent, yahoo still avoids gzip, avoiding the issue.

True fix: upgrade/replace/avoid the problem proxy server. Work-arounds: forge a
non-Mozilla/5 userAgent similar to above; or leave userAgent as Mozilla/5 but
config to disable transmit of accept-encoding:gzip in prefs.js by:

user_pref("network.http.accept-encoding", "");
Product: Browser → Seamonkey

Comment 22

13 years ago
Resolving as WFM.  Comments indicate that this was either a server-side or proxy
problem.  If anyone disagrees, feel free to reopen and provide more info.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.