Closed Bug 237589 Opened 18 years ago Closed 18 years ago

Proxy Configuration does not allow selection of Authenticate with logged in User Account

Categories

(Core :: Networking: HTTP, enhancement)

x86
Windows XP
enhancement
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 231529

People

(Reporter: jeremyl, Assigned: darin.moz)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

Proxy Configuration does not allow selection of Authenticate with logged in User
Account. The proxy configuration page in preferences does not have an option to
use the local user authentication (instead of password manager) to pass the
authentication to the proxy server thus bypassing the need for typing a password
into password manager. This could be dynamic depending on the person loging into
the machine. This would be particularly useful in an environment with Directory
Authentication where the proxy is authenticating users based on a single signon. 

Reproducible: Always
Steps to Reproduce:
1. Specify a Proxy server that requires Authentication in the Firefox 8
preferences field. 
2. Browse to a webpage that uses the proxy to filter or cache content.
3. You will now see a prompt from password manager to enter a username and
password. 

Actual Results:  
You need to reinter your domain password and user ID that was already used to
log into the machine. 

Expected Results:  
The software should have given the option when selecting a proxy to use the
local user account for authentication. If the local user wasn't authenticated
for login to the proxy then the password manager should prompt for a user ID and
password. 

A user would only have to log into the local Windows machine and the
authentication details could be passed to the proxy if preselected and
authentication would be seamless. 

This feature would be usefull in Corporate environments.
-> Networking
Assignee: prefs → darin
Component: Preferences → Networking: HTTP
QA Contact: httpqa

*** This bug has been marked as a duplicate of 231529 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.