[PP] www.geocities.com: Complex, nested tables don't render on Mac Viewer

VERIFIED FIXED in M2

Status

Core Graveyard
Viewer App
P2
major
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: Eli Goldberg, Assigned: Pierre Saslawsky)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
* TITLE/SUMMARY
[PP] www.geocities.com: Complex, nested tables don't render on Mac Viewer

* STEPS TO REPRODUCE
0) Launch Viewer
1) View www.geocities.com

* RESULT
 - What happened

All that renders is the "G" in the upper-left hand corner, and the banner ad.
None of the rest of the page content (a big set of nested tables containing the
bulk of the content) is not rendered.

I've managed to blow away half of the HTML code and still have most of the
problematic layout, but I fear that complex table layout decomposition just ain't
my thing.

 - What was expected

Output equivalent to Win32 build.

* REGRESSION

 - Occurs On
        viewer (1.14.99 optimized build for Mac OS)
        viewer (1.13.99 optimized build for Mac OS)

 - Doesn't Occur On
        viewer (1.14.99 optimized build for Win32 [NT 4, Service Pack 3])
        Communicator 4.5 (Mac OS RTM)

 - Haven't Checked
        viewer (1.13.99 optimized build for Linux --- build is broken)


* CONFIGURATIONS TESTED

- PowerMac 8500/120 (233 Mhz 604e), 64 MB RAM, 1024x768 (16-bit video), Mac OS
8.5.1

Updated

19 years ago
Assignee: sdagley → pierre
Severity: normal → major

Comment 1

19 years ago
Marking as severity=major as it's not a crash or development blocker.

Eli, does any site but GeoCities exhibit this problem?  If not, this should be
downgraded to severity=normal as it may be related to the GeoBranding layer stuff
which GeoCities uses to advertise their free web pages.

Reassigning to pierre as it's a core issue and may need to be resolved in Gecko
land.  Kick it back if you don't agree and we can find a new owner.
(Reporter)

Comment 2

19 years ago
Hi, Steve ---

I have seen a multitude of other web sites in which portions of tables do not
render, although I do not know off the top of my head those were Mac-specific.

In this case, I don't believe I saw any layers used in the web page (and removing
the <!-- <SERVICE NAME="watermark"> --> section containing the watermark
Javascript didn't have any effect, which I did as part of the original bug
investigation, but neglected to note.)
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

19 years ago
Something really good happened in the last few days. I'm not sure what exactly
but it works now.

Marking Fixed.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

19 years ago
A miracle does appear to have happened.

Specifically:
	* the bug does occur as documented when browsing the geocities page with the
1.15.99 build
	* the bug does not occur anymore (as Pierre notes) when browsing the page
with the 1.21.99 build.

Thus, Verified fixed.

Comment 5

19 years ago
Inserting Milestone info.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.