Closed Bug 237778 Opened 17 years ago Closed 17 years ago

update filter list in t/004template

Categories

(Bugzilla :: Testing Suite, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Bugzilla 2.18

People

(Reporter: goobix, Assigned: goobix)

Details

Attachments

(1 file, 1 obsolete file)

We should probably add the ics filter to the testing suite. It's already in 008
but it's missing from 004.
Attachment #144120 - Flags: review?(kiko)
Vlad, help me out here and find out if the format here has to be compatible with
the Template.pm format (i.e., filters taking arguments need to have be function
generators).
Gerv, William: any know-how regarding the comment above?
Status: NEW → ASSIGNED
It should probably look like the bug_link line.

            ics => [ sub { return sub { return $_; } }, 1] ,
If you want to fix up the closed/obsolete/inactive filters we added yesterday
too I'd be real happy about it.
Attached patch Version 2Splinter Review
Sorry for the delay.
Attachment #144120 - Attachment is obsolete: true
Attachment #144120 - Flags: review?(kiko)
Attachment #144471 - Flags: review?(kiko)
Target Milestone: --- → Bugzilla 2.18
Comment on attachment 144471 [details] [diff] [review]
Version 2

Looks good, but I'm wondering: when are these used if the tests are running
fine now?
Attachment #144471 - Flags: review?(kiko) → review+
Flags: approval?
Flags: approval? → approval+
Summary: ics filter not added to t/004filter test → update filter list in t/004template
Checking in t/004template.t;
/cvsroot/mozilla/webtools/bugzilla/t/004template.t,v  <--  004template.t
new revision: 1.32; previous revision: 1.31
done
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.