Closed for bug entry should be on version basis

RESOLVED DUPLICATE of bug 77193

Status

()

Bugzilla
Administration
P3
enhancement
RESOLVED DUPLICATE of bug 77193
15 years ago
6 years ago

People

(Reporter: Ajay Dwivedi, Assigned: justdave)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: 

As of now we set "Closed for bug entry" on a per product basis. As a result, 
till a product has new versions coming, the bugs can be reported in any of the 
older versions. Since each version of the product has its lifecycle, the 
versions soon become outdated and there is no use of bugs being reported in 
older versions. For example, a bug being reported in version 1.0 of mozilla is 
of no use. It is not going to be fixed, nor is it of any help if the bug does 
not exist in the newer version. It just wastes the precious time of the 
maintainer.
Also, this creates problem of the cluttering of versions while submitting the 
bugs leading to submission of bug into a wrong version.

I suggest the following feature:
Allow the versions table to have a disallownew field like the products table. 
While creating a new bug, a user should be shown only the versions that do not 
have disallownew turned on. This would allow a more granular control over the 
bug submission. We can still have the disallownew field in products table 
which would work as it works now.

I would like this feature to be in bugzilla. Though in my opinion, it does not 
require a big change, just adding a field in the versions table and some 
change in queries for getting version list for a product.

If others feel this feature may be good to be included in the product, I can 
try hacking the bugzilla with my scarce knowledge of perl.

Reproducible: Always
Steps to Reproduce:

Comment 1

14 years ago
This is a good idea, but it needs a solution to keep the query interface from
getting badly cluttered as a huge number of ancient versions remain queryable.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3

*** This bug has been marked as a duplicate of 77193 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.