Add additional keyword substitution to BugMail

RESOLVED DUPLICATE of bug 70710

Status

()

Bugzilla
Email Notifications
--
enhancement
RESOLVED DUPLICATE of bug 70710
14 years ago
5 years ago

People

(Reporter: Albert Ting, Assigned: preed)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

BugMail should make available bug specific keywords to user defined templates.
For example, it would be nice if one could specify the product/component in the 
newchangedmail parameter.  While not necessary for new bugs, this is useful 
when getting new bug comments.  Below is a simple patch to show my point.

--- bugzilla-2.17.7/Bugzilla/BugMail.pm	Sun Jan 25 23:04:22 2004
+++ Bugzilla/BugMail.pm	Thu Mar 18 02:03:33 2004
@@ -847,6 +849,8 @@
     $substs{"reasonsheader"} = join(" ", @reasons);
     $substs{"reasonsbody"} = $reasonsbody;
     $substs{"space"} = " ";
+    $substs{"product"} = $values{'product'};
+    $substs{"component"} = $values{'component'};
     
     my $template = Param("newchangedmail");
     


Reproducible: Always
Steps to Reproduce:

Comment 1

14 years ago
Thanks for the bug report. This particular bug has already been reported into
our bug tracking system, but please feel free to report any further bugs you find.

*** This bug has been marked as a duplicate of 70710 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.