[Spellcheck] Include common Mozilla words like Mozilla, Firefox, XUL in shipped dictionary

RESOLVED FIXED

Status

()

Core
Spelling checker
--
enhancement
RESOLVED FIXED
14 years ago
8 years ago

People

(Reporter: Scott MacGregor, Assigned: Matt Caywood)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
...with common mozilla words like Mozilla, Firefox, XUL, etc.

This needs to be a locale dependent custom dictionary that gets copied into the
user's profile directory for new profiles if one does not exist already.

Comment 1

14 years ago
Is there something about these words meaning that the end user will want to
remove them?  Otherwise, why not just put them straight into the regular
dictionaries?
Product: MailNews → Core

Comment 2

11 years ago
wasn't this idea "killed" at some point in the last couple years?
Severity: normal → enhancement
OS: Windows XP → All
Hardware: PC → All

Comment 3

11 years ago
I have been told that the reason for not adding these words to the regular dictionaries is that it makes it more difficult to accept updates from these dictionaries and libraries as they are incrementally improved (ie., we'd have to get our changes pushed upstream, or else add yet another build/release step for patching them in).  Adding a default or extra custom dictionary so that "Firefox" and "Mozilla" aren't suggested as spelling errors seems like a good idea to me; if we can do it easily, we should do it.

Updated

10 years ago
Assignee: mscott → nobody
QA Contact: esther → composition
Product: Core → MailNews Core

Comment 4

9 years ago
If this ever happens, it should be in a file different from the personal dictionary. The personal dictionary should really be only words that the user manually added himself.

This sounds more like a build improvement of the dictionary files - we should keep our additions separate and then merge them.
(Assignee)

Comment 5

9 years ago
A problem with using the personalized dictionary is that currently personalized dictionaries aren't used for suggestions, etc. (bug 338291).

It may also create problems in the future if the main dictionary is cached in some way to speed up processing -- I believe there's a bug on this somewhere.

I agree with Ben in comment #4. The work I'm doing in bug 479334 includes some scripts that should make it relatively easy to update upstream dictionaries without losing Mozilla-specific changes.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX

Comment 6

9 years ago
(In reply to comment #5)
> A problem with using the personalized dictionary is that currently personalized
> dictionaries aren't used for suggestions, etc. (bug 338291).
> 
> It may also create problems in the future if the main dictionary is cached in
> some way to speed up processing -- I believe there's a bug on this somewhere.

you may be thinking of bug 470471, Bug 468779 or  Bug 384999

Comment 7

9 years ago
Caywood, thanks for looking into this!

I think we should have a bug to track the problem (not the solution), though. Do you mind, if I reopen this bug and change the summary from "Ship a default custom dictionary file" to "Include common Mozilla words like Mozilla, Firefox, XUL in shipped dictionary"?
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Summary: Ship a default custom dictionary file → [Spellcheck] Include common Mozilla words like Mozilla, Firefox, XUL in shipped dictionary
(Assignee)

Comment 8

9 years ago
OK Ben, that seems a reasonable way to track this issue. 

Upon thinking about it some more, this is a larger issue than 479334 and applies to multiple language dictionaries. 

If the solution in Bug 479334 solves the problem satisfactorily, we can resolve this one.
Depends on: 479334
(Assignee)

Comment 9

9 years ago
Created attachment 383537 [details]
mozilla-specific word list

OK, I went through http://www.mozilla.org/projects/ and http://en.wikipedia.org/wiki/Mozilla and came up with a list of reasonably current projects and trademarks that I thought might be worth including in dictionaries in all languages.

Some of these are currently in the en-US dictionary, but many are not.

Suggestions welcome.
Assignee: nobody → caywood
Let's get this in the right product/component.
Assignee: caywood → nobody
Component: Composition → Spelling checker
Product: MailNews Core → Core
QA Contact: composition → spelling-checker

Updated

9 years ago
Assignee: nobody → caywood

Comment 11

8 years ago
This does not depend on bug 479334.
No longer depends on: 479334

Comment 12

8 years ago
Comment 5 said:
> The work I'm doing in bug 479334 includes some
> scripts that should make it relatively easy to update upstream dictionaries
> without losing Mozilla-specific changes.

Given that this is fixed, do we now have the technical means to add our own words to the standard English dictionary?
(Assignee)

Comment 13

8 years ago
Ben, there are two options now for adding words. 

In the en-US/hunspell/dictionary-sources directory there's a large (but more manageable reasonably sized) patch to the hunspell standard English dictionary, upstream-hunspell.diff, which contains normal dictionary words that will hopefully get upstreamed at some point.

I am trying to batch changes to this file in Bug 499593.

There is also mozilla-specific.txt which is based on the work above. This contains words that Mozilla wants included but are (1) unlikely to be upstreamable and (2) can be added to any language dictionary.

There's currently not a bug for batching changes to this file, but if you have suggestions, please open one.

Comment 14

8 years ago
Matt, are you saying we just need to add the words to the file
mozilla-specific.txt ? If so, where is it?
<http://mxr.mozilla.org/comm-central/find?string=mozilla-specific.txt>
shows no match
(Assignee)

Comment 15

8 years ago
Hi Ben, it should be there. See the landing from Bug 479334.

http://hg.mozilla.org/mozilla-central/rev/e227a12b97a5

But note: if you modify mozilla-specific.txt (or any of the new dictionary files), you will need to run the merge-dictionaries script to generate a new dictionary.

See README_mozilla.txt for explanation and instructions.

Comment 16

8 years ago
So, this *does* not only depend on bug 479334, but was fixed by it:

<http://hg.mozilla.org/mozilla-central/file/e227a12b97a5/extensions/spellcheck/locales/en-US/hunspell/dictionary-sources/mozilla-specific.txt>

So, marking this FIXED by Matt.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago8 years ago
Depends on: 479334
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.