The string to be searched is left on the 'search mozilla' search box after the window is refreshed

VERIFIED DUPLICATE of bug 46845

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 46845
14 years ago
13 years ago

People

(Reporter: Tauhida Parveen, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040210 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040210 Firefox/0.8

Type a string to search for in the 'search mozilla' search box at
www.mozilla.org. Click the back button and press F5 use use the refresh icon to
refresh the browserand the back button is pressed, Click on the back button and
press F5 or use the refresh icon to refresh the browser


Reproducible: Always
Steps to Reproduce:
1.Start Mozilla’s Firefox browser window
2.select the 'search mozilla' search box and type a string to search for.
3.Click on the back button and press F5 or use the refresh icon to refresh the
browser


Actual Results:  
The search string that was searched for is still left on the search box

Expected Results:  
After pressing F5, the search box should be cleared out.

Use the same strategy using Internet explorer or opera as the browsers.
Internet explorer clears the search box when the back button on the browser is
used. Opera clears the search box when the refresh button is used after the back
button is used.

This feature is also tested using www.fit.edu and www.cs.fit.edu URLs and using
the search boxes that were available in those URLs. The above mentioned results
are obtained in all of the searches.
This comes down to a difference between "Reload" and "Refresh"  Shift-F5 or
Shift and clicking on Refresh in the toolbar clear the page completely.  Refresh
by default simply rerenders the page.  AFAIK, this is intentional behaviour, as
it allows a refresh to not destroy data in forms etc if someone clicks refresh.

Just because other browsers make other choices does not make it a bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Summary: The string to be searched is left on the 'search mozilla' search box after the window is refreshed → The string to be searched is left on the 'search mozilla' search box after the window is refreshed

Comment 2

14 years ago
mconnor: the difference between F5 and Shift+F5 is more subtle than that.  F5 is
"reload", which sends an if-modified-since request to the server.  Shift+F5 is
"force reload", which always downloads a fresh version from the server.  They
might also have different behaviors wrt images in the page (don't check, check,
force-reload images).  I'm not sure what the interaction with proxies is.

Reopening because this is a dup of bug 46845.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.