Closed Bug 237954 Opened 20 years ago Closed 20 years ago

"nsAccessibleHyperText::GetLink" doesn't return proper link

Categories

(Core :: Disability Access APIs, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: Louie.Zhao, Assigned: aaronlev)

Details

Attachments

(2 files)

"nsAccessibleHyperText::GetLink" makes assumption that link node is the parent
of text node. Actually link node may be grandparent (or grand-grand-parent, ...)
of text node (e.g. in the testcase, the structure of "Item 3" is "A(link) ->
B(bond) -> Text"). This patch changes the code for "searching link node for text
node".
Attached file testcase
Enviornment: GNOME 2.5.91; Gnopernicus 0.7.6

Reproduce step:
1. using "tab" to move focus to item1,2,....

Expected result:
gnopernicus display "LNK Item1", "LNK Item2", "LNK Item3", "LNK Item4"
correspondingly.

Actual result:
gnopernicus won't display "LINK Item3","LINK Item4","LINK Item5"
Attached patch patch v1Splinter Review
Attachment #144295 - Flags: review?(kyle.yuan)
Attachment #144295 - Flags: review?(kyle.yuan) → review+
Comment on attachment 144295 [details] [diff] [review]
patch v1

sr = Henry
Attachment #144295 - Flags: superreview+
Thanks for r and sr. Patch checked in.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
This bug is not yet fixed, because the patch was checked in but later backed out.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Ignore comment 5 - this patch was not backed out.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: