Closed Bug 238036 Opened 21 years ago Closed 20 years ago

Build fail at tools/leaky/bfd.cpp with error "xpcom-config.h" not found

Categories

(SeaMonkey :: Build Config, defect)

x86
Linux
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.8alpha1

People

(Reporter: thetemplar, Unassigned)

References

Details

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040319
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040319

I was building mozilla-1.7-beta and It fails on this :

g++ -o bfd.o -c -DOSTYPE=\"Linux2.6\" -DOSARCH=\"Linux\"   -I../../dist/include
-I../../dist/include -I/home/gamer/Sources/mozilla/dist/include/nspr    
-I/usr/X11R6/include   -fPIC  -I/usr/X11R6/include -fno-rtti -fno-exceptions
-Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth
-Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -pedantic
-fshort-wchar -pthread -pipe  -DDEBUG -D_DEBUG -DDEBUG_gamer -DTRACING -g
-fno-inline  -I/usr/X11R6/include -DMOZILLA_CLIENT -include
../../mozilla-config.h -Wp,-MD,.deps/bfd.pp bfd.cpp
Dans le fichier inclus à partir de bfd.cpp:13:
leaky.h:22:47: xpcom-config.h : Aucun fichier ou répertoire de ce type
In file included from bfd.cpp:13:
leaky.h:54: error: erreur d'analyse syntaxique before `;' token
gmake[2]: *** [bfd.o] Erreur 1
gmake[2]: Leaving directory `/home/gamer/Sources/mozilla/tools/leaky'
gmake[1]: *** [tier_50] Erreur 2
gmake[1]: Leaving directory `/home/gamer/Sources/mozilla'
make: *** [default] Erreur 2

Here are my configure flags :
./configure --prefix=/opt/Mozilla --sysconfdir=/etc
--enable-default-toolkit=gtk2 --enable-calendar --enable-xft --disable-svg
--enable-leaky --enable-strip --enable-xterm-updates
--with-gtk-prefix=/opt/Gnome26/lib/

I did a small patch that fixes the problem, maybe you can take a look at it


Reproducible: Always
Steps to Reproduce:
1. Pick up the sources of Mozilla 1.7 beta
2. Pass the flag --enable-leaky to the configure script
3. Then make

Actual Results:  
It fails with that error :

g++ -o bfd.o -c -DOSTYPE=\"Linux2.6\" -DOSARCH=\"Linux\"   -I../../dist/include
-I../../dist/include -I/home/gamer/Sources/mozilla/dist/include/nspr    
-I/usr/X11R6/include   -fPIC  -I/usr/X11R6/include -fno-rtti -fno-exceptions
-Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth
-Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -pedantic
-fshort-wchar -pthread -pipe  -DDEBUG -D_DEBUG -DDEBUG_gamer -DTRACING -g
-fno-inline  -I/usr/X11R6/include -DMOZILLA_CLIENT -include
../../mozilla-config.h -Wp,-MD,.deps/bfd.pp bfd.cpp
Dans le fichier inclus à partir de bfd.cpp:13:
leaky.h:22:47: xpcom-config.h : Aucun fichier ou répertoire de ce type
In file included from bfd.cpp:13:
leaky.h:54: error: erreur d'analyse syntaxique before `;' token
gmake[2]: *** [bfd.o] Erreur 1
gmake[2]: Leaving directory `/home/gamer/Sources/mozilla/tools/leaky'
gmake[1]: *** [tier_50] Erreur 2
gmake[1]: Leaving directory `/home/gamer/Sources/mozilla'
make: *** [default] Erreur 2


Expected Results:  
Find xpcom-config.h which is in (topsrcdir)/xpcom/xpcom-config.h
Attached patch This should fix the problem (obsolete) — Splinter Review
Comment on attachment 144357 [details] [diff] [review]
This should fix the problem

http://www.mozilla.org/hacking/portable-cpp.html#include_simple_filename

The proper fix would be to add xpcom to the REQUIRES variable in the Makefile.
Attachment #144357 - Flags: review-
*** Bug 243497 has been marked as a duplicate of this bug. ***
Attachment #144357 - Attachment is obsolete: true
Confirming bug since cls has spun a patch.
Status: UNCONFIRMED → NEW
Ever confirmed: true
The patch has been checked in.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.8alpha
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: