Mozilla silently dies on 'Switch Profile...', due to 'general.startup.*' prefs setting

RESOLVED FIXED

Status

SeaMonkey
Startup & Profiles
--
minor
RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: sgautherie, Assigned: Andrew Schultz)

Tracking

({fixed-seamonkey1.1a})

Trunk
fixed-seamonkey1.1a
Bug Flags:
blocking1.7 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [verified-seamonkey1.1a])

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040316] (W98SE)

I have 2 Mozilla profiles (and 6 unmigrated NetscapeV4 profiles);
I can start both my Mozilla profiles;
I can swich successfully from my v1.3 to my v1.7a profile;
but I can't do it the other way round.

Reproductible: 100%

Steps:
1. Start Mozilla with my v1.7a profile
2. 'Tools > Switch Profile...'
3. Select my v1.3 profile
3-R. Mozilla silently stops/dies, instead of re-appearing with v1.3 profile.

Workaround:
4. Restart Mozilla: v1.3 profile is active.
4-R. Then: The "back-end" switch succeeded, but the "UI" failed to restart
dynamically at step 3.
(Reporter)

Comment 1

14 years ago
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7a) Gecko/20040219] (W98SE)

Bug already there in v1.7a.
(Reporter)

Comment 2

14 years ago
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040421] (<-- 1.7rc1 !)
(W98SE)

In fact, it can happen with any of my 2 profiles:

Working case:
{{
user_pref("general.startup.browser", false);
user_pref("general.startup.mail", true);
}}
(MailNews starts)

Failing case:
{{
user_pref("general.startup.browser", false);
}}
(Nothing starts)

It appears that, in the latter case, the switching process would need to "guess"
which "default" app. to start !
I would suggest:
1) the one from which the Switch process was started.
2) in any case, start something.
3) (or, at the very least, "_say_ goodbye")
Flags: blocking1.7?
Summary: Mozilla silently dies on 'Switch Profile...' from v1.7a profile to v1.3 profile → Mozilla silently dies on 'Switch Profile...', due to 'general.startup.*' prefs setting
Currently I'm working on the reintegration of the profile switching UI in
Firefox and Thunderbird as an extension. I had the same behavior with Firefox
till the 0.8 release. Builds created later on the 0.9 trunk are still switching
with the same preferences to the other profile. Currently I can reproduce the
silent stop of Thunderbird during the profile switching. Using a debug build the
last message I receive is following code:

http://lxr.mozilla.org/seamonkey/source/xpcom/io/nsStreamUtils.cpp#441
-> "Continue Event not posted"

http://lxr.mozilla.org/seamonkey/source/profile/src/nsProfile.cpp#1287
-> "DefineLocaleDefaultsDir failed - NS_SUCCEEEDED"

I don't know if the behavior of Thunderbird is caused on the same background
like you have written here. Can you use a debug build of Mozilla to verify the
last reaction during the switching?

The preferences you mentioned Thunderbird doesn't use. I also removed all
entries from prefs.js and Thunderbird isn't starting again. But starting
manually after the silent stop is working.
(Reporter)

Comment 4

14 years ago
(In reply to comment #3)
> Can you use a debug build of Mozilla to verify the
> last reaction during the switching?

Where can I get a (W98SE) debug build ?

Comment 5

14 years ago
edge case that we don't have any fix in sight for. not going to block but we'd
consider a reviewed patch for 1.7
Flags: blocking1.7? → blocking1.7-
Product: Browser → Seamonkey
(Assignee)

Comment 6

12 years ago
Created attachment 219492 [details] [diff] [review]
make the return value useful

<sigh>
Assignee: nobody → ajschult
Status: NEW → ASSIGNED
Attachment #219492 - Flags: review?(neil)

Updated

12 years ago
Attachment #219492 - Flags: review?(neil) → review+
(Assignee)

Updated

12 years ago
Attachment #219492 - Flags: approval-branch-1.8.1?(neil)
(Assignee)

Comment 7

12 years ago
fixed on trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
OS: Windows 98 → All
Hardware: PC → All
Resolution: --- → FIXED

Updated

12 years ago
Attachment #219492 - Flags: approval-branch-1.8.1?(neil) → approval-branch-1.8.1+
(Assignee)

Updated

12 years ago
Keywords: fixed-seamonkey1.1a
(Reporter)

Comment 8

12 years ago
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8) Gecko/20060424 SeaMonkey/1.1a] (tinderbox-builds, 2006042413) (W98SE)

V.Fixed on 1.8.1 branch:
in the previously failing case, a browser window now opens.

(I think this might be good to have in 1.8.0 branch too, but I leave it to you to decide.)
Whiteboard: [verified-seamonkey1.1a]
You need to log in before you can comment on or make changes to this bug.