Focus is not set correctly when closing tabs

NEW
Unassigned

Status

SeaMonkey
Tabbed Browser
15 years ago
6 years ago

People

(Reporter: Scott Minster, Unassigned)

Tracking

({testcase})

Trunk
x86
All
testcase
Bug Flags:
wanted-seamonkey2.0 +
blocking-seamonkey2.0 -
blocking-seamonkey2.0b1 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.6) Gecko/20040208
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.6) Gecko/20040208

When closing a tab, another is correctly selected.  However, the focus is
sometimes misplaced.  For example, the focus may be placed in the URL bar.  In
that case, pressing Ctrl+W to close the newly selected tab doesn't close the
tab, but instead deletes the contents of the URL bar.  Or, pressing space to
scroll down in the newly selected tab causes a space to be appended to the URL
(you get the idea).  I have also seen the focus being given (invisibly, as there
is not visible clue this is being done) to a bookmark in the Personal Toolbar
Folder.  This happens as described in the steps to reproduce.

Reproducible: Always
Steps to Reproduce:
1. Open a tab to a web page with a lot of text (so you can scroll down)
2. Right click on a bookmark in the personal toolbar folder and select "open in
new tab".
3. Once the new tab has loaded, close it.
4. Press space in the previous tab.  Instead of scrolling down, the bookmark
from step 2 is loaded.

Actual Results:  
The bookmark from step 2 is loaded.

Expected Results:  
The previous tab should have scrolled down.

Comment 1

14 years ago
I see this on LInux 2004042605

Updated

14 years ago
Blocks: 140346

Comment 2

14 years ago
I filed a bug report:  251877

that turns out a duplicate of this bug.  I've documented a slightly different
behavior to this as for me, this bug isn't always reproducible, but only on some
websites.  In a single window at the same time, I can have tabs from site#1 that
work fine and have tabs from site#2 where focus is a problem.  Just a FYI.

Comment 3

13 years ago
what i see in linux running 1.03, 1.04, and 1.05 is very frequent.  the focus goes
to the previous tab.

Comment 4

13 years ago
WFM FF1.5 windows
Linux users - does this now WFY?
(Reporter)

Comment 5

13 years ago
I can reproduce this using Mozilla 1.7.12 on Gentoo Linux, but not with FireFox (1.0.7, Gentoo Linux).  I'm not sure I've ever seen this type of problem in FF.

Comment 6

13 years ago
this was a mozilla only bug for me

Comment 7

11 years ago
Cannot reproduce on Firefox 3/Trunk. [Space] scrolls page down.

Please close as WORKSFORME or INVALID.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Comment 8

11 years ago
This bug is not about Firefox, it's about Mozilla Suite/SeaMonkey. It shouldn't have been resolved based on comment #7.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 9

11 years ago
OMG... SeaMonkey should have dropped support - it stops Firefox development and releases.

Comment 10

11 years ago
Valerio, Andrew, do you see this? (UNCO after 4 years is hot useful)

Comment 11

11 years ago
Jakub, my memory must be failing -- which firefox release was it that was stopped by SeaMonkey?

anyway, I do see this bug with seamonkey branch as well as 2008-02-03-trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is stopping Firefox releases.

Four yrs old bug... I am sure it will not be fixed.

Comment 13

11 years ago
reproduced only once on:
Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.8.1.12) Gecko/20080201 SeaMonkey/1.1.8

Comment 14

11 years ago
selecting:
Edit, Preferences, Tabbed Browsing, Switch to new tabs opened from links,
then close Seamonkey, start it again, happen always.
Deselecting that check box, close and restart Seamonkey, happen rarely.
(Assignee)

Updated

10 years ago
Product: Core → SeaMonkey

Comment 15

9 years ago
Testcase is in comment 1 and comment 14. 

In Windows, this bug appears. Instead of opening the tab, though, spacebar does nothing. Instead of the spacebar scrolling page down, it does not work. 


Nominating for blocker status.
Flags: blocking-seamonkey2.0b1?
Keywords: testcase
OS: Linux → All
Assignee: tabbed-browser → nobody
QA Contact: tabbed-browser

Comment 16

9 years ago
Not blocking for beta 1 but should probably block release. Please renominate.
Flags: blocking-seamonkey2.0b1? → blocking-seamonkey2.0b1-
Flags: blocking-seamonkey2?

Comment 17

9 years ago
We can afford to ship 2.0 without this, so not blocking, but if a fix comes up, we'd want to have it in.
Flags: wanted-seamonkey2.0+
Flags: blocking-seamonkey2.0?
Flags: blocking-seamonkey2.0-
I can see this in Firefox 3.5 on Linux. Sometimes while mass-killing tabs with Ctrl-W tabs stop closing and I have to click the content to close the tab.

Perhaps related to bug 337215
You need to log in before you can comment on or make changes to this bug.