Attach signature path and choose button do not always disable correctly

RESOLVED FIXED

Status

RESOLVED FIXED
15 years ago
14 years ago

People

(Reporter: iann_bugzilla, Assigned: neil)

Tracking

({verified1.7})

Trunk
x86
Windows XP
verified1.7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
Using Build ID 2004031910 on WinXP SP1
Steps to reproduce
1. Create at least two mail accounts and make sure attach signature is unchecked
on them all
2. Bring up Mail & Newsgroups Account Settings
3. Note that signature path/choose button are disabled in the default account
4. Select second account and look at signature path/choose button

Expected results
1. signature path/choose button are disabled because the attach signature
checkbox is unchecked

Actual results
1. signature path/choose button are enabled despite the attach signature
checkbox being unchecked.

If you have more than two accounts it is the same for other accounts with
unchecked attach signature checkboxes. If you select outgoing server and then an
accounts main options page then the signature path/choose button are correctly
disabled.
(Assignee)

Comment 1

15 years ago
Oh that's weird... even if you were originally on an account with a signature
then when you change to an account without a signature then the path and choose
button are disabled, but if you change to a third account without a signture
then they are reenabled...
(Assignee)

Comment 2

15 years ago
OK, so what's happening is this... the locked state is updated by
AccountManager.js which unlocks the controls every time. The disabled state is
then reset by am-main.js, but that hits the broadcaster rather than the controls
themselves. Now (thanks to bz's attribute notification optimization patch?)
since the broadcaster is already disabled it doesn't notifiy the controls, as a
result the controls remain enabled.
(Assignee)

Comment 3

15 years ago
Created attachment 144562 [details] [diff] [review]
Proposed patch
Assignee: sspitzer → neil.parkwaycc.co.uk
Status: NEW → ASSIGNED
(Assignee)

Updated

15 years ago
Attachment #144562 - Flags: superreview?(mscott)
Attachment #144562 - Flags: review?(mscott)

Comment 4

15 years ago
Comment on attachment 144562 [details] [diff] [review]
Proposed patch

good find Neal.
Attachment #144562 - Flags: superreview?(mscott)
Attachment #144562 - Flags: superreview+
Attachment #144562 - Flags: review?(mscott)
Attachment #144562 - Flags: review+
(Assignee)

Updated

15 years ago
Target Milestone: --- → mozilla1.8alpha
(Assignee)

Comment 5

15 years ago
Comment on attachment 144562 [details] [diff] [review]
Proposed patch

Fairly low-risk patch to fix UI nit.
Attachment #144562 - Flags: approval1.7?

Comment 6

15 years ago
Comment on attachment 144562 [details] [diff] [review]
Proposed patch

a=asa (on behalf of drivers) for checkin to 1.7
Attachment #144562 - Flags: approval1.7? → approval1.7+
(Assignee)

Comment 7

15 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Keywords: fixed1.7
Resolution: --- → FIXED
Target Milestone: mozilla1.8alpha → ---

Comment 8

15 years ago
Verified as fix on latest 1.7 branch 06-24 builds for all the platforms.
Changing keywords from fixed1.7 to verified1.7.
Leave this bug status "as is" until this bug be verified on trunk again...
Keywords: fixed1.7 → verified1.7
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.