Firefox doesn't start when general.useragent.override is set to MS Internet Explorers User Agent.

VERIFIED DUPLICATE of bug 83376

Status

()

defect
VERIFIED DUPLICATE of bug 83376
15 years ago
15 years ago

People

(Reporter: mozilla.org, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.6) Gecko/20040318 Firefox/0.8

I use the Extension "User Agent Switcher", which makes it easy to switch the
User Agent. A few days ago I forgot to set the User Agent back to "Default" and
Firefox denied to start "with a browser version < 5".
After removing the line "general.useragent.override" all worked fine again.

Reproducible: Always
Steps to Reproduce:
1. set general.useragent.override to "Mozilla/4.0 (compatible; MSIE 6.0; Windows
NT 5.1)
2. shutdown Firefox
3. try to start Firefox

Actual Results:  
A warning message appears. Firefox doesn't start until the useragent is
corrected in the file prefs.js

Expected Results:  
Start the browser (with a modified user-agent)

Comment 1

15 years ago
WFM

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040321 Firefox/0.8.0+

Comment 2

15 years ago
If disabling Java fixes it, this is a dup of bug 83376.
(Reporter)

Comment 3

15 years ago
Disabling Java helps indeed. I never thought that this could be a Java-bug
because the error-message says nothing about Java:
----
INTERNAL ERROR on Browser End: Expected a version > 5! Version = 4
 
System error?:: Datei oder Verzeichnis nicht gefunden
----
The last line is partly german and means: "File or directory not found"

*** This bug has been marked as a duplicate of 83376 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.