gbdate.h has unresolvable dependency upon layout static libs

RESOLVED DUPLICATE of bug 83405

Status

SeaMonkey
Build Config
RESOLVED DUPLICATE of bug 83405
14 years ago
13 years ago

People

(Reporter: Artur Polaczynski, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040219
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040324

make clean in any directroy (but not root) ie layout,content,etc,
don't remove symliks from dist/lib.
Build fail in this dir by dependies to dist/lib/something_s.a (this is broken
symlink)

ps I know thais is not recomended
pss make clean in root dir works
psss sorry for my bad english


Reproducible: Always
Steps to Reproduce:
1. make -f client.mk build as usual
2. cd layout ; make clean ;  cd ..
3. make -f client.mk build 

Actual Results:  
fail because dependies

Expected Results:  
normal build

Comment 1

14 years ago
This shouldn't be a problem with every directory.  Just layout.  This is fallout
from bug 83405.  The central 'clean' rule does not remove anything from dist/ so
the $(wildcard) finds a file when it normally wouldn't.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: make clean in any directroy (not root), don't remove symliks from dist/lib. Build fail in this dir → gbdate.h has unresolvable dependency upon layout static libs

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 83405 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.