Courier-IMAP: Shared folders disappear when I exit and re-lauch Mail

RESOLVED DUPLICATE of bug 239868

Status

RESOLVED DUPLICATE of bug 239868
15 years ago
10 years ago

People

(Reporter: b03, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316

Shared folders disappear when I exit and re-lauch Mail.  To get them back, I
must collapse, then re-expand the folders hierarchy by clicking twice on the
arrow to the left of the account name.  Was not an issue with 1.6 stable, but
was an issue with 1.4.  My settings (as they worked flawlessly in 1.6, but not
in 1.5) are:

IMAP server directory: INBOX.
Personal namespace: "INBOX."
Public (shared): "shared.","#shared."

The above settings show all IMAP folders including shared folders, and personal
folders do not appear as sub-folders of inbox.  The newly added IMAP IDLE
functionality works well.

Reproducible: Always
Steps to Reproduce:
1.  Install courier-imap-3.0.2 with either filesystem or virtual shared folders
2.  Install Mozilla Mail 1.7 with the settings shown above
3.  Once all shared folders are visible, exit and re-start mail

Actual Results:  
Shared IMAP folders disappeared, until I collapsed, then re-expanded the folders
hierarchy.

Expected Results:  
The shared IMAP folders should "stick" - i.e. remain in the folders hierarchy

Modern theme
(Assignee)

Comment 1

15 years ago
Can you attach an imap protocol log by following these instructions?

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap

thx.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

15 years ago
dup of 239868 - if so, today's nightly 1.7b build will have the fix and the next
daily thunderbird builds as well.

*** This bug has been marked as a duplicate of 239868 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.