When deleting a contact from the address book, it does not get deleted from the .mab file as well

RESOLVED DUPLICATE of bug 65086

Status

SeaMonkey
MailNews: Address Book & Contacts
RESOLVED DUPLICATE of bug 65086
15 years ago
14 years ago

People

(Reporter: Massimiliano Pala, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8

When deleting one contact from the address book, e.g. from collected adresses or
personal addresses, the corresponding entry does not get deleted from the .mab
file. Althought the contact is no more (correctly) displayed in the list, this
behaviour is a problem because these files (.mab) constantly grow in size.

Reproducible: Always
Steps to Reproduce:
1. Open the address book
2. Chose one contact from the book
3. Delete the entry

Actual Results:  
Correctly the deleted entry is no more listed among the available ones, however
its data is still present in the corresponding .mab file.

Expected Results:  
The software should remove the entry data from the .mab file after deleting an
entry from the address book. Another solution to the problem would be the adding
of a menu entry/button for compacting the addresses, i.e. "Compact Address
Book", like the one available for the Mail folders.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 65086 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.