templatization went amuck in "reassign_to_empty" error

RESOLVED FIXED in Bugzilla 2.18

Status

()

Bugzilla
User Interface
--
minor
RESOLVED FIXED
15 years ago
6 years ago

People

(Reporter: timeless, Assigned: Christopher Nehren)

Tracking

unspecified
Bugzilla 2.18
Bug Flags:
approval +

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

15 years ago
626   [% ELSIF error == "reassign_to_empty" %]
627     [% title = "Illegal Reassignment" %]
628     You cannot reassign to [% terms.abug %] to nobody. Unless you
629     intentionally cleared out the "Reassign [% terms.bug %] to"
630     field, [% Param("browserbugmessage") %]

reassign to a bug to nobody.

um sure. fixme.
(Assignee)

Comment 1

15 years ago
Created attachment 144777 [details] [diff] [review]
fixme'd.

Updated

15 years ago
Assignee: myk → apeiron
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → Bugzilla 2.18

Updated

15 years ago
Status: NEW → ASSIGNED
Flags: approval?

Updated

15 years ago
Attachment #144777 - Flags: review+

Comment 2

15 years ago
Comment on attachment 144777 [details] [diff] [review]
fixme'd.

What if we went ahead and improved this phrase? The reason I'm saying this is
that "nobody" is now ambiguous given that certain sites (bmo for instance) use
nobody@foo.com accounts as bug assignees. My suggestion:

'To reassign [% terms.abug %], you must provide an address for the new owner.
If you did not intentionally clear out the "Reassign...'
Attachment #144777 - Flags: review-

Comment 3

15 years ago
Comment on attachment 144777 [details] [diff] [review]
fixme'd.

Per kiko's comments.
Attachment #144777 - Flags: review+
Flags: approval?
Chris, do you have a few minutes to update this, or would you like someone else
to tackle it?
(Assignee)

Comment 5

14 years ago
Created attachment 148367 [details] [diff] [review]
Here's an updated patch based on current CVS.

This patch reflects changes inspired by comments made after I posted the first
patch.
Flags: approval+

Updated

14 years ago
Attachment #144777 - Attachment is obsolete: true

Comment 6

14 years ago
Checking in user-error.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/user-error.html.tmpl,v
 <--  user-error.html.tmpl
new revision: 1.61; previous revision: 1.60
done
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 7

14 years ago
*** Bug 251288 has been marked as a duplicate of this bug. ***
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.