Unable to use multiple clients on same account at same time

RESOLVED DUPLICATE of bug 239802

Status

MailNews Core
Networking: IMAP
RESOLVED DUPLICATE of bug 239802
14 years ago
9 years ago

People

(Reporter: John L. Villalovos, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316

Using IMAP (via SSL if important).  Using Mozilla 1.7b (was NOT occuring with
Mozilla 1.7a).

If I leave my home computer running Mozilla Mail and then go to work and try to
access my email via IMAP I am unable to get a lock on my mailbox.  I am unable
to delete mail messages or even change their state from unread to read.

Here is output from my /var/log/maillog
Mar 21 18:30:00 webhost imapd[28770]: Authenticated user=john host=sodarock.com
[216.99.200.244]
Mar 21 18:30:00 webhost imapd[28771]: imaps SSL service init from 216.99.200.244
Mar 21 18:30:00 webhost imapd[12173]: Killed (lost mailbox lock) user=john
host=sodarock.com [216.99.200.244]
Mar 21 18:30:01 webhost imapd[28771]: Authenticated user=john host=sodarock.com
[216.99.200.244]
Mar 21 18:30:08 webhost imapd[28783]: imaps SSL service init from 216.99.200.244
Mar 21 18:30:08 webhost imapd[28783]: Authenticated user=john host=sodarock.com
[216.99.200.244]
Mar 21 18:33:57 webhost imapd[28784]: imaps SSL service init from 216.99.200.244
Mar 21 18:33:57 webhost imapd[28784]: Authenticated user=john host=sodarock.com
[216.99.200.244]
Mar 21 18:33:57 webhost imapd[28770]: Killed (lost mailbox lock) user=john
host=sodarock.com [216.99.200.244]

I am using the imap-2002d-3 server that comes with Fedora Core 1.  The page for
the IMAP server is: http://www.washington.edu/imap/



Reproducible: Always
Steps to Reproduce:
1. Have Mozilla Mail running and attached
2. Try to use another client to read or delete emails
3. Unable to delete emails or change state from unread to read.
(Assignee)

Comment 1

14 years ago
this is a limitation of your server...
(Reporter)

Comment 2

14 years ago
Any reason this bug appeared in 1.7beta and not before that?  In 1.7alpha I did
not have any issues.

Just curious.  Since the server hasn't changed.
(Assignee)

Comment 3

14 years ago
oh, yeah - probably because we had to back out a fix to the shutdown code
because it sometimes causes hangs shutting down...so my mistake, it's really a
problem with the client code (most servers handle the way we shutdown fine, but
the UW server does not)
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

14 years ago
Cool :)  Thanks for looking in to it.

Comment 5

14 years ago
just for reference, the current mozilla simply does NOT work with itself on a UW
imapd.  both mozillas have to constantly be taken offline/online just to get a
halfway fresh reading of what emails are in your mailboxes.  updates such as msg
deletion, msgs marked read, etc, don't happen.

mozilla used to work great like this.  i could leave several machines up and
running with my mail client on each one and they'd all be happy.  now i have to
go offline with all of them and only be online with the one i want to use at
that particular desk i'm sitting at for the minute.  really defeats the purpose.
(Assignee)

Comment 6

14 years ago
Does your UW server support the IDLE command, and what happens if you set
Mozilla not to use the IDLE command? There's  a UI to turn off IDLE use in
Mozilla, in the advanced imap server settings, if you get the most recent build.
(Assignee)

Comment 7

14 years ago
dup of bug 239802, which is now fixed.

*** This bug has been marked as a duplicate of 239802 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 8

14 years ago
Just tried the Mozilla 1.7RC1 and everything is working great now :)
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.