Can't invoke context menu in about:config until an item is selected

RESOLVED DUPLICATE of bug 191410

Status

--
minor
RESOLVED DUPLICATE of bug 191410
15 years ago
14 years ago

People

(Reporter: vdvo, Assigned: vdvo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 obsolete attachments)

(Assignee)

Description

15 years ago
In about:config, you can't use click the right mouse button on empty space to
invoke the context menu until an item in the list is selected. Therefore, when
the list is empty, there doesn't seem to be a way to add a new preference.

Steps to reproduce:
1. go to about:config
2. type "qweqwe" in the Filter text field
3. there are now no preferences displayed; try adding a new pref - apparently,
you can't
4. now type "eat_space" in the Filter field
5. there is now exactly one preference displayed, but not selected
6. click the right mouse button in the empty space below the one displayed pref
- nothing happens
7. select the one displayed pref with the left mouse button
8. repeat step 6 - now, the right mouse button works

Comment 1

15 years ago
Created attachment 145728 [details] [diff] [review]
Patch to fix describe behaviour.

Patch against xpfe/global/resources/content/config.js

Updated

15 years ago
Attachment #145728 - Flags: review?(alecf)

Comment 2

15 years ago
Comment on attachment 145728 [details] [diff] [review]
Patch to fix describe behaviour.

why do you touch the elements individually in the first case, and with a for
loop in the second case? Fix this inconsistency at the very least..
(Assignee)

Comment 3

15 years ago
Created attachment 145822 [details] [diff] [review]
patch version 2

Here's a new patch. No for cycle, added comments.

Also, I noticed a JavaScript warning and error when you press Enter when
nothing is selected. This patch corrects that, too - I hope you don't mind me
not filing a new bug for this one-line addition (plus indentation).
Assignee: prefs → vdvo
Attachment #145728 - Attachment is obsolete: true
Status: NEW → ASSIGNED
(Assignee)

Comment 4

15 years ago
Comment on attachment 145822 [details] [diff] [review]
patch version 2

Do we need sr, too, or is Alec's review sufficient?
Attachment #145822 - Flags: review?(alecf)
(Assignee)

Updated

15 years ago
Attachment #145728 - Flags: review?(alecf)

Comment 5

15 years ago
Comment on attachment 145822 [details] [diff] [review]
patch version 2

I need to sr=, you need to get a front end UI person to r= this.
sr=alecf
Attachment #145822 - Flags: review?(alecf) → superreview+
(Assignee)

Updated

15 years ago
Attachment #145822 - Flags: review?(neil.parkwaycc.co.uk)

Comment 6

15 years ago
Whoops, this conflicts with a patch I just added for bug 191410 :-(

Comment 7

14 years ago
This will be fixed by bug 191410: "new" in the context menu is enabled even when
there's no selection and you're clicking on an empty space. The fix for that has
full reviews already, just needs checkin.

*** This bug has been marked as a duplicate of 191410 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey

Updated

14 years ago
Attachment #145822 - Attachment is obsolete: true
Attachment #145822 - Flags: review?(neil.parkwaycc.co.uk)
You need to log in before you can comment on or make changes to this bug.