Closed Bug 239086 Opened 17 years ago Closed 17 years ago

"Save as" taking too long

Categories

(SeaMonkey :: Download & File Handling, defect)

x86
Windows ME
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 159107

People

(Reporter: mail, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.6) Gecko/20040113

Attempting to save images using 'right-click, save image as'. The process
appears to hang for about 20 seconds before the progress dialog appears.

Reproducible: Always
Steps to Reproduce:
1. Right-click an image
2. Select 'Save image as'
3. Click Save

It should be noted at this point that the same thing happens regardless of the
type of file being saved.



Actual Results:  
Nothing happens for about 20 seconds, then the progress dialog appears and the
download proceeds as normal.

Expected Results:  
The progress dialog should appear almost immediately and the download start.

This *may* somehow be related to the number of items in the download manager.
I'm not sure how the DM works as I don't use it per se, but I have noticed that
I do not get this problem if there are no items listed in the DM. It seems to be
a case of the more items in the DM, the longer the download process takes to start.

This brings up a related issue as to why items are being added to the DM list
when I don't directly use the DM (I have no idea if this is supposed to happen
or not, it just seems odd) and how I can clear the lengthy DM list without it
hanging completely.
One thing I forgot to mention, the same thing happens if I try and save an
inline image in an email but NOT if I right-click and save as in the attachments
box.
To get rid of the files in downloadmanager just delete downloads.rdf in your
profile, when mozilla is not running. An empty file will be recreated at next start.

*** This bug has been marked as a duplicate of 159107 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.