Status

VERIFIED DUPLICATE of bug 68877
15 years ago
10 years ago

People

(Reporter: richard, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.6) Gecko/20040117
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.6) Gecko/20040117

Mozilla uses the domain part of the identity's email address for EHLO and HELO.
However, according to RFC 2821 (and RFC 821), a fully-qualified domain name
identifying the domain name should be used, see 4.1.1.1 Extended HELLO (EHLO) or
HELLO (HELO). The RFC also says:
>>
   -  The domain name given in the EHLO command MUST BE either a primary
      host name (a domain name that resolves to an A RR) or, if the host
      has no name, an address literal as described in section 4.1.1.1.
<<

So I think it would be correct to:
* make a connection to the SMTP server
* use getsockname() to get the IP address of the interface used to connect
* call gethostbyaddr() onto the IP address
* if there is a result, use it, else use [ IP address ]

What do you think about this?

Reproducible: Always
Steps to Reproduce:

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 68877 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.