Last Comment Bug 239130 - when I change href of a <link "css"> with setAttribute, colors is ok but not <div> position.
: when I change href of a <link "css"> with setAttribute, colors is ok but not ...
Status: RESOLVED WORKSFORME
: qawanted
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://leiopar.free.fr/DISKETTE/bug_g...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-29 16:23 PST by mozillabug
Modified: 2004-08-03 13:10 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Testcase (430 bytes, text/html)
2004-06-22 13:08 PDT, Eli Friedman
no flags Details
Better testcase (788 bytes, text/html)
2004-06-22 18:04 PDT, Eli Friedman
no flags Details

Description mozillabug 2004-03-29 16:23:07 PST
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; fr-FR; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; fr-FR; rv:1.6) Gecko/20040113

In the page at
http://leiopar.free.fr/DISKETTE/bug_gecko/setAttribute_css/setAttribute_css.html,
when you change listbox value from "bleu foncé" to "beige foncé", it's ok.
But if you change to "cadre jaune", the positions of <div> are not following.   

Reproducible: Always
Steps to Reproduce:
1.open :
http://leiopar.free.fr/DISKETTE/bug_gecko/setAttribute_css/setAttribute_css.html
2.change "CSS :" listbox to "cadre jaune"


Actual Results:  
the position of the <div> they are not good

Expected Results:  
the position of the <div> change like the color of the new css

note: the probleme is solved when I begin to use mousegesture.
thank you
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2004-03-29 19:39:17 PST
This bug could use a minimal testcase.
Comment 2 mozillabug 2004-03-30 03:05:47 PST
(In reply to comment #1)
> This bug could use a minimal testcase.

What ? :/
Comment 3 Boris Zbarsky [:bz] (still a bit busy) 2004-04-01 17:45:18 PST
Exactly what I said.  It would be easier to determine what's going on given a
page with absolutely the smallest amount of HTML and CSS necessary to reproduce
the bug.
Comment 4 Jesiah S 2004-05-04 14:19:22 PDT
I see this on LInux 2004050306. "cadre jaune" is not the only one that causes
this.  It seems to happen randomly.
Comment 5 Eli Friedman 2004-06-22 13:08:26 PDT
Created attachment 151467 [details]
Testcase

This is a very strange bug.  All the elements in the testcase are required to
reproduce the problem.
Comment 6 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2004-06-22 15:51:45 PDT
What is this testcase supposed to do that it's not doing now?
Comment 7 Eli Friedman 2004-06-22 18:04:27 PDT
Created attachment 151494 [details]
Better testcase

This version has some added descriptive text.
Comment 8 Boris Zbarsky [:bz] (still a bit busy) 2004-07-29 23:29:37 PDT
So.. the testcases in this bug workforme as far as I can tell.

So does the site, though it may be that I'm missing a problem there -- there's a
lot of noise and comment 0 doesn't actually specify what the problem is.
Comment 9 Eli Friedman 2004-08-02 11:19:40 PDT
Just checked; WFM in current builds.
Comment 10 mozillabug 2004-08-03 10:00:24 PDT
Ok, I'll explain again.
When I load this page :
http://leiopar.free.fr/DISKETTE/bug_gecko/setAttribute_css/setAttribute_css.html

I have this :
http://leiopar.free.fr/DISKETTE/bug_gecko/setAttribute_css/step1.png
It's ok.

When I choose "cadre jaune" in the popup-menu, i have that :
http://leiopar.free.fr/DISKETTE/bug_gecko/setAttribute_css/step2.png
the positions of the divs are not good.

But when i try to make a mousegesture i have that :
http://leiopar.free.fr/DISKETTE/bug_gecko/setAttribute_css/step3.png
the positions become well, like the file "res/cadrejaune.css" say.

Idem when, at this stage, i try to choose "beige foncé" :
http://leiopar.free.fr/DISKETTE/bug_gecko/setAttribute_css/step4.png

And, with mousegesture :
http://leiopar.free.fr/DISKETTE/bug_gecko/setAttribute_css/step5.png

note : Now I ave Mozilla 1.7 and FireFox 0.9
Comment 11 Eli Friedman 2004-08-03 10:21:30 PDT
It doesn't work in 1.7; however, it works in current builds. Try something more
recent than 1.7 (like a recent nightly; download at
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest/).
Comment 12 mozillabug 2004-08-03 10:54:41 PDT
Ok !
With Mozilla 1.8 bug is down !
So... 
Thank you to everyone who develop Mozilla !

Note You need to log in before you can comment on or make changes to this bug.