HTML code inside IFRAME-s parsed, when BODY tag missing

RESOLVED INVALID

Status

()

RESOLVED INVALID
15 years ago
5 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

Mozilla parses the HTML code inside the IFRAME, when BODY tag missing from the
document. <BODY> tag is optional, so the page is valid. you can check with
http://validator.w3.org/.

Reproducible: Always
Steps to Reproduce:
1. open the specified URL

Actual Results:  
javascript alert will popup, and open <iframe src="...">

Expected Results:  
just open the <iframe src="...">
Hmm.. this is the usual problem with us hoisting <script>s up to <head> when
there is no <body> (unfortunately needed for compat with IE and NS4 in many cases).

Marking dependent, but this is most likely going to be a duplicate...
Depends on: 178258
Whiteboard: DUPEME
I suspect this was probably fixed with the checkin for bug 88952, but the
testcase given in the url is a 404. Reporter, can you check again with a recent
trunk nightly?
QA Contact: mrbkap
Marking INVALID based on lack of information. If new information surfaces, feel
free to reopen. Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.