<hr> not rendering in coded color and line is very thin

RESOLVED DUPLICATE of bug 190655

Status

()

RESOLVED DUPLICATE of bug 190655
15 years ago
5 years ago

People

(Reporter: luckyarthur550, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040329
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040329

My CSS had the following Element code:

HR {
	color : #FF0000;
	background : transparent;
}
*********************************************
This renders properly in red in I.E. 6.0 and the thickness of the line is
somewhat substantial. In Mozilla the line is off-white and quite thin.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
Mozilla treats HR as a block-level element and IE does not, so the CSS required
is different for each browser.  In Mozilla you have to set the background-color
to get a color change.

Try this for good cross-browser compatibility:

hr {
  background : #FF0000;
  border : 1px solid #FF0000;
  color : #FF0000;
  height : 1px;
}
Ian, do you think it would make sense to just use an inset border and set the
color of HR in ua.css?  That way setting both color and border-color from author
sheets will have the same effect....

And if that would make sense, don't we already have a bug on making
-moz-bg-inset a color, not a style?
Whiteboard: DUPEME
There is a bug suggesting we just nuke all the -bg- styles, making the HR colour
be based on the foreground text colour instead of the background colour. I would
not be opposed to this.

If we want to keep using the background colour, though, then yes, we should
change from using three styles to simply using the normal styles (inset, outset,
solid) and supporting a new color (-moz-bg-color) that works everywhere.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 5

13 years ago
*** Bug 310560 has been marked as a duplicate of this bug. ***

Comment 6

13 years ago

*** This bug has been marked as a duplicate of 190655 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.