Image alt text is NOT displayed when placing the mouse over the image

VERIFIED DUPLICATE of bug 25537

Status

Core Graveyard
Embedding: ActiveX Wrapper
VERIFIED DUPLICATE of bug 25537
14 years ago
6 years ago

People

(Reporter: Michael Volikas, Assigned: Adam Lock)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040320
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040320

I noticed that the alt text was not displayed when the Mozilla WebBrowser
control  is embedded in a VB6 program.  This was confirmed using the VBrowse
test harness from
http://lxr.mozilla.org/seamonkey/source/embedding/browser/activex/tests/vbrowse/

Reproducible: Always
Steps to Reproduce:
1.  Compile the VBrowse test harness
2.  Go to www.cnn.com and place the mouse over one of the news pictures
3.  The alt text should be displayed

Actual Results:  
The alt text is NOT displayed

Expected Results:  
The alt text should be displayed.

Perform the above steps using Mozilla and the alt text is displayed


The Mozilla WebBrowser control (mozctl.dll) is missing this functionality when
you compare it to Microsoft's shdocvw.dll.

Comment 1

14 years ago
How is this any different from the fact that we simply don't show alt text in
the browser? (bug 25537, verified wontfix)

Comment 2

14 years ago
It's not any different.

ALT text is not supposed to and will not be shown that way.

*** This bug has been marked as a duplicate of 25537 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED

Comment 4

14 years ago
actually, it is different. activex control already significantly deviates from
standards support to emulate ie.
(Assignee)

Comment 5

14 years ago
Well it doesn't significantly deviate at all :) It's just a wrapper around Gecko
using the IE interfaces.

However I believe this bug is a dupe of bug 239233 since I don't show tooltips
even for TITLE attributes. The tooltip text provider service can also be
replaced so I could show ALT as well, but getting the normal behaviour would be
a good start.
(Assignee)

Comment 6

14 years ago
Ooops, I meant dupe of 239037.

Comment 7

14 years ago
you support document.all in the control, which is in opposition to the view of
the core gecko developers. i consider that a fairly significant deviation. (i
can understand why you'd do it,...)
(Assignee)

Comment 8

14 years ago
The control API implements the IHTMLDocument::get_all property and other IE
specific properties but only for the benefit of embedders. Content can't call
the IE interfaces at all and it is rendered and behaves exactly as if it were
any other Gecko app.
Component: Embedding: ActiveX Wrapper → Embedding: ActiveX Wrapper
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.