Should use the real tab's URL instead of about:blank so that user can refresh or reload.

RESOLVED DUPLICATE of bug 231393

Status

()

--
minor
RESOLVED DUPLICATE of bug 231393
15 years ago
15 years ago

People

(Reporter: ouan, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040216 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040216 Firefox/0.8.0+

When try to open a new tab or window by a hyperlink, if the page cannot be
reached or there is any error, the URL in the new tab/windows will be
"about:blank".  It should be the url of the hyperlink so that user can just use
"Go" to reload it.

Frequently that happens and user forgot which page they were trying to see.

Reproducible: Always
Steps to Reproduce:
1. Follow a deadlink that can produce about:blank in the new window/tab
2. The URL will be about:blank instead of the hyperlink URL.
3. Cannot use refresh.  Forget already which page to open.

Actual Results:  
1. Follow a deadlink that can produce about:blank in the new window/tab
2. The URL will be about:blank instead of the hyperlink URL.

Expected Results:  
The URL should be the one that try to open.
Firefox issue.
Assignee: general → firefox
Component: Browser-General → General
Product: Browser → Firefox
Version: Trunk → unspecified

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 231393 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.