Closed Bug 23925 Opened 20 years ago Closed 19 years ago

want personal control panel for saying which email notifications you want

Categories

(Bugzilla :: Bugzilla-General, enhancement, P3)

enhancement

Tracking

()

VERIFIED DUPLICATE of bug 17464

People

(Reporter: ekrock, Assigned: justdave)

Details

It would be nice if Bugzilla users could specify (via a control panel of
checkboxes) which kinds of email notifications they personally did/did not want
to receive.
Examples of possible checkbox controls: check yes or no to be notified for:
- change QA contact (as PM, I don't care that much)
- change assigned engineer (also care little about this)
- confirmed DUP (don't tell me what I already know! ;-> )
- confirmed INVALID (ditto)
- change dependency (not worth an email in my mind)
- change URL
- Summary field

Usually people *would* want to be notified of:
- new bugs on them
- reopened bugs on them
- bugs that change to be assigned to them

I recognize that checking all these settings after a bug edit on all the people
on the cc: list might create performance problems for Bugzilla.
The real problem is that this doesn't work with the current architecture of
email notifications.  At all.
Status: NEW → ASSIGNED
This was originally talked about in general in bug #14137.  I'll leave this as
the main bug for this specific issue since that bug has become confused.

From that bug:

---

I put a comment on bug #37345 (BCC) about separating resolution only and normal
notification, and bug #17464 talked about settable change triggers to prevent
dependency spam.

---

A notification class is the combination is a bug match condition (the default
here is when you're on CC, reporter, etc.) and a change trigger condition on
those bugs.  The change triggers are what this bug talks about.

From that bug again:

---

Each notification class could define a set of "keywords", for want of a better
term, that appears in the subject line for the criterion of this class.  This
could allow better and easier filtering than any "body search" since it is
Bugzilla specific.

---

The subject line "keywords" proposal would also aid an implementation of bug
#26943, which would further reduce spam.
QA Contact: matty
tara@tequilarista.org is the new owner of Bugzilla and Bonsai.  (For details,
see my posting in netscape.public.mozilla.webtools,
news://news.mozilla.org/38F5D90D.F40E8C1A%40geocast.com .)
Assignee: terry → tara
Status: ASSIGNED → NEW
Having just disected the email code in order to resolve the lack of "New Email 
Tech" mails to QA Contacts, I can counter Terry's comment that it won't fit in 
the current architecture.  Based on what I saw in the email code, as long as the 
user is using the New Email Tech, this should be relatively painless to 
implement.

*** This bug has been marked as a duplicate of 17464 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Verified dupe.
Status: RESOLVED → VERIFIED
moving to Bugzilla product
reassign to default owner/qa for INVALID/WONTFIX/WORKSFORME/DUPLICATE
Assignee: tara → justdave
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: other → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.