Certificate viewer not visible when it's supposed to be, locking the browser tab/window.

RESOLVED DUPLICATE of bug 242275

Status

--
critical
RESOLVED DUPLICATE of bug 242275
15 years ago
14 years ago

People

(Reporter: nc, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040316

If I go to a page that makes the certificate viewer to show up (i.e. expired
certificate, certificate for wrong host, unknown issuer, etc.), sometimes the
Certificate Viewer wouldn't show. The page would still "spin" (throbbing M,
status bar on bottom still scrolling, etc), and would not go anywhere until I
either kill the tab or window. 

Then, when I actually do a Command-Q to quit Mozilla altogether, the said
Certificate Viewer popup would magically appear.

Reproducible: Sometimes
Steps to Reproduce:
1. Go to a https site that has an SSL certificate that would produce a
certificate error.
2. Select "accept cert for this session"
3. Cert viewer should appear here, but doesn't. Note that if you go to the
Window menu bar, the Certificate Viewer would be listed as a showing Window.
(Always)
4. Only way to get out of this jam (on this particular tab) is to kill the tab
or window. (Always)
5. When you quit Mozilla altogether, the Certificate Viewer would sometimes show
up. (only Sometimes)
Actual Results:  
See "Details". Makes viewing pages that might have an invalid/self-signed
certificate hard.

Expected Results:  
Certificate viewer to show up for my inspection. If I click OK, then the browser
window would show the https'ed page.

Reproducible (not every time though) it on Mozilla 1.6, 1.7a, 1.7b, all on Mac.
Tried brand new profile, both Classic or Modern skins, didn't help.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 242275 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.