drop down list of position:fixed select element is displayed at wrong positions

RESOLVED FIXED in Camino1.0

Status

RESOLVED FIXED
15 years ago
14 years ago

People

(Reporter: shy, Assigned: sfraser_bugs)

Tracking

({fixed1.8})

unspecified
Camino1.0
PowerPC
macOS
fixed1.8

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040317 Camino/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040317 Camino/0.7+

I suppose it has to do with the call to scrollIntoView();
After experimenting with the examples funcions, the select element's drop down
list does not get displayed at it's propper position any more.
It seems to get "scrolled away" with the page

Reproducible: Always
Steps to Reproduce:
1. go to
http://www.din.or.jp/~hagi3/JavaScript/JSTips/Mozilla/Samples/ScrollIntoView.htm
2. use the example's controlls to scrollIntoView the different boxes.
3. see where the drop down list gets displayed next.

Actual Results:  
drop down list's position becomes detached from the select element

Expected Results:  
...

Comment 1

15 years ago
Definitely shouldn't do that, and I'm seeing it as well with 20040330. The 0.8
Firefox release shows the correct behavior
Status: UNCONFIRMED → NEW
Ever confirmed: true

*** This bug has been marked as a duplicate of 235850 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
Not a dupe. This is actually just due to having the select in a position:fixed.
The menu thinks that it's scrolling with the page.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 4

15 years ago
Created attachment 147770 [details]
reduced testcase

Scroll around; the select is fixed but the menu thinks it should be moving.

Updated

15 years ago
Summary: drop down list of select element is displayed at wrong positions → drop down list of position:fixed select element is displayed at wrong positions
ah, yes
Status: REOPENED → ASSIGNED
Target Milestone: --- → Camino1.0
I think this bug was meant for HTML Form Controls, not History :-)
Component: History → HTML Form Controls
(Assignee)

Comment 7

14 years ago
Patch in bug 235850 will fix this.
Assignee: mikepinkerton → sfraser_bugs
Status: ASSIGNED → NEW
Depends on: 235850
(Assignee)

Comment 8

14 years ago
Fixed, trunk and branch.
Status: NEW → RESOLVED
Last Resolved: 15 years ago14 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.