Internet Keywords: connecton refused, going to alternate web sites

VERIFIED DUPLICATE of bug 184433

Status

()

defect
VERIFIED DUPLICATE of bug 184433
16 years ago
15 years ago

People

(Reporter: jebabhas, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

When I type http://localhost:[some port] in the address line, the browser is
redirected to alternate pages instead of showing host not found page. For
example, if I enter http://localhost:9000 and a server is not listening on that
port, I am redirected to http://www.localhost.net.au/. I thought this might be
feature and looked in options and couldn't find anything that seems related to
this 'feature'. I tried in Mozilla 1.6 and IE and can not reproduce on those
browsers.

Reproducible: Always
Steps to Reproduce:
1.Enter http://localhost:[some port]
2.
3.

Actual Results:  
If a server is not running on local host, redirected to other web pages

Expected Results:  
Show a host not found page or page can not displayed message.
This is a known bug.  It was fixed before Firefox 0.8 was released, but because
0.8 was the result of work at fixing problems on a copy of the source code made
before that (and pretty much *only* fixing problems - very few new features or
risky bug fixes, only urgent problems that required immediate attention), 0.8
doesn't have this fix.  Firefox 0.9 will work correctly, as will any of the
recent Firefox nightlies if you're inclined to test one out.

Recent nightlies have been relatively stable as long as you don't attempt to
import old settings using Firefox itself, but your mileage may vary.

*** This bug has been marked as a duplicate of 184433 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
V/dupe.
Reopen if this is happening w/ 0.9
Status: RESOLVED → VERIFIED
BTW, "host not found" usually means that the name doesn't exist in DNS.

In your case, your system did not answer for that port, that is a different error.
QA Contact: benc
Summary: If the host is not found, going to alternate web sites → Internet Keywords: connecton refused, going to alternate web sites
You need to log in before you can comment on or make changes to this bug.