<input type="file"> cannot be resized with CSS width attribute + lack of repaint

RESOLVED DUPLICATE of bug 52500

Status

--
trivial
RESOLVED DUPLICATE of bug 52500
15 years ago
10 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113

It isn't possible to set the CSS width: attribute for an <input> Element
of type="file". See the URL for further detail.


Reproducible: Always
Steps to Reproduce:
1. attempt to set the css-width of <input type="file">
Actual Results:  
The element is not resized.
Additionally, the area, that would be occupied in case the width would have been
accepted, is not filled with the specified background-color.

Expected Results:  
The element is resized by the browser flawlessly.
(Reporter)

Comment 1

15 years ago
Created attachment 145263 [details]
... demonstrates incorrect rendering of <input> element

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 52500 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Summary: <input type="file"> cannot be resized with CSS width attribute + lack of repaint → <input type="file"> cannot be resized with CSS width attribute + lack of repaint
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.