form variable not sent when alt text is used in input type=image tag

RESOLVED DUPLICATE of bug 122238

Status

()

RESOLVED DUPLICATE of bug 122238
15 years ago
10 years ago

People

(Reporter: mozilla.org, Assigned: dveditz)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113

When the browser displays the "alt text" for an "input type=image" tag, the form
data for that tag is not sent to the server when the user clicks on the button.

Let's take the following HTML:

<form method=post>
<input type=image src=none.gif alt='button'>
<input type=image src=button.gif alt='button'>
</form>

Assuming that "none.gif" does not exist and "button.gif" does exist, this will
create type buttons.  The first will use the alt text "button", and the second
will use the image button.gif.

If you click on the second, the following form data will be sent to the web server:

Content-Length: 7
x=6&y=6

(I got this via the "Live HTTP headers" add-on).

However, if you click on the first button, no form data is sent at all! The web
server has no idea that the user clicked on the button.


Reproducible: Always
Steps to Reproduce:
Fixed in 1.7 builds.

*** This bug has been marked as a duplicate of 122238 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: Form Manager → Form Manager
Product: Core → Toolkit
QA Contact: form.manager
You need to log in before you can comment on or make changes to this bug.