Closed Bug 239586 Opened 17 years ago Closed 17 years ago

Tell Firefox not to import bookmarks for first time running

Categories

(Firefox :: General, enhancement)

x86
Windows XP
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 240136

People

(Reporter: roboco, Assigned: bugzilla)

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0) Opera 7.23  [en]
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040403 Firefox/0.8.0+

When unzip Firefox (http://ftp.mozilla.org/pub/mozilla.
org/firefox/nightly/latest-trunk/Firefox-win32.zip) and start it for the first 
time on a Windows XP or Windows 2000 PC, Firefox automatically imports 
(presumably) IE bookmarks without giving the user a chance to say NO. Please 
make it possible for the user to say YES or NO at the Import Bookmars dialog 
before starting to import bookmarks.

Reproducible: Always
Steps to Reproduce:
1.Unzip http://ftp.mozilla.org/pub/mozilla.
org/firefox/nightly/latest-trunk/Firefox-win32.zip to a folder on a Windows XP 
or Windows 2000 machine that never has Firefox/Firebird/Phoenix/Mozilla 
installed before.
2.Watch out for Import Bookmarks dialog when Firebird is starting for the first 
time.
3.Try to stop Firebird from importing Bookmarks.

Actual Results:  
1.Click on Bookmarks menu and you'll see a lot of imported bookmarks there.
2.Click on Address Bar and you'll see a lot of addresses there.


Expected Results:  
Ask user first if they want to import bookmarks. Let them say YES or NO.
This feature will add a dialogue box that every Windows user new to Firefox will
see. It prevents Firefox from just working after an install which is one of the
features of Firefox. My recomendation is that this be marked won't fix.

*** This bug has been marked as a duplicate of 240136 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
QA Contact: mconnor
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.