Lock file still present upon reboot after unclean shutdown (system crash)

RESOLVED DUPLICATE of bug 151188

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 151188
14 years ago
13 years ago

People

(Reporter: Frederik Dannemare, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040401 Debian/1.6-4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040401 Debian/1.6-4

I had a system crash earlier today. I rebooted and tried to start mozilla, but
the lock file was still present after this unclean mozilla shutdown (due to
system crash). This causes a usability-bug (at least for inexperienced users)
since the Profile Manager pops up, and the lock file has to be removed manually.
I have had system crashes before for various reasons, but this is the first time
I've run into this problem with mozilla's lock file. How can we overcome this
issue, you think? 

Reproducible: Sometimes
Steps to Reproduce:
1. Well, start Noatun - play some video files - exit Noatun -> system crash :)
(I think it's an artsd-related (KDE sound daemon) crash)
2. Reboot
3. Execute Mozilla

Actual Results:  
Mozilla's Profile Managaer pops up, because it sees the lock file (even though
no mozilla instance is running)

Expected Results:  
Use some other way of determining whether mozilla is actually running, instead
of relying solely on the lock file (which can be an old lock file still present
in the filsystem due to a total system crash, thus not allowing mozilla to shut
down in a proper way).

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 151188 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.